Power Strings (KMP求循环次数)

题目:https://vjudge.net/contest/243048#problem/G

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

KMP求循环次数:

不过有个问题。我第一次的代码是这样的:但是他WA

#include <iostream>
#include <string.h>
#include <stdio.h>
#define maxn 1000010
using namespace std;
int fail[maxn];
char temp[maxn];
void getFail(int n) {					//n表示短字符串的长度
  int i = 0, j = -1;						//i表示短字符串当前位置,j表示当前位置之前的部分前缀和后缀相同的个数-1
	fail[0] = -1;							//fail数组表示当前位置匹配失败后从短字符串之前哪个位置继续匹配
	while(i < n) {
		if(j==-1 || temp[i]==temp[j])		//temp数组用来存储短字符串
		{
			++i, ++j;
			if(temp[i] != temp[j]) fail[i] = j;
			else fail[i] = fail[j];
		}
		else j = fail[j];
	}
}
int main()
{
   while(1)
   {
       scanf("%s",temp);
       if(strcmp(temp,".")==0)break;
       int m=strlen(temp);
       getFail(m);
       int n=m-fail[m];
       printf("%d\n",m/n);
   }
    return 0;
}

 第二次是这样的,他就奇迹般地通过了。

因为我想的是如果里边没有循环节,那么最小循环节的长度就是他自己本身的长度,但是这样会WA,之后分开讨论,就给过了。所以不太明白。

#include <iostream>
#include <string.h>
#include <stdio.h>
#define maxn 1000010
using namespace std;
int fail[maxn];
char temp[maxn];
void getFail(int n) {					//n表示短字符串的长度
  int i = 0, j = -1;						//i表示短字符串当前位置,j表示当前位置之前的部分前缀和后缀相同的个数-1
	fail[0] = -1;							//fail数组表示当前位置匹配失败后从短字符串之前哪个位置继续匹配
	while(i < n) {
		if(j==-1 || temp[i]==temp[j])		//temp数组用来存储短字符串
		{
			++i, ++j;
			if(temp[i] != temp[j]) fail[i] = j;
			else fail[i] = fail[j];
		}
		else j = fail[j];
	}
}
int main()
{
   while(1)
   {
       scanf("%s",temp);
       if(strcmp(temp,".")==0)break;
       int m=strlen(temp);
       getFail(m);
       int n=m-fail[m];
       if(m%n==0)
       printf("%d\n",m/n);
       else printf("1\n");
   }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值