Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd aaaa ababab .
Sample Output
1 4 3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
题意:给一个字符串,求它是由最小循环节循环几次得到的,即要先找出最小循环节,在用总长度除以最小循环节即可,
要找最小循环节,必要先找到最大前后缀和,假设ans为最大前后缀和,则ans = nxt [ L -1 ] ( L为字符串的长度),于是,最小循环节等于L - ans ,此外还要在判断一下,如果L% (L - ans)!=0 说明这个字符串就没有循环节,输出 1 即可,反之输出L / (L - ans)。
#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;
const int M=1e6+10;
char s[M];//不要用string ,老是TLE // CE
int nxt[M];
int l;
void kmp(){
nxt[0]=0;
int j=0;
int i=1;
while(i<l){
if(s[i]==s[j]){
nxt[i]=++j;
i++;
}
else if(!j){
i++;
}
else{
j=nxt[j-1];
}
}
}
int main()
{
while(scanf("%s",s)){
if(s[0]=='.') return 0;
l=strlen(s);
memset(nxt,0,sizeof(nxt));
kmp();
int ans=nxt[l-1];//最大前后缀和
if(l%(l-ans)!=0) printf("1\n");//最小循环节
else{
ans=l/(l-ans);
printf("%d\n",ans);
}
}
return 0;
}