HDU5914

HDU5914
Triangle
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1413 Accepted Submission(s): 840

Problem Description
Mr. Frog has n sticks, whose lengths are 1,2, 3⋯n respectively. Wallice is a bad man, so he does not want Mr. Frog to form a triangle with three of the sticks here. He decides to steal some sticks! Output the minimal number of sticks he should steal so that Mr. Frog cannot form a triangle with
any three of the remaining sticks.

Input
The first line contains only one integer T (T≤20), which indicates the number of test cases.

For each test case, there is only one line describing the given integer n (1≤n≤20).

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of sticks Wallice should steal.

Sample Input
3
4
5
6

Sample Output
Case #1: 1
Case #2: 1
Case #3: 2

Source
2016中国大学生程序设计竞赛(长春)-重现赛

Recommend
wange2014

Statistic | Submit | Discuss | Note
解析:
20以内从小往大删:
1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20
1+2=3删掉2-3的数,2+3=5删掉3-5之间的数,3+5=8删掉5-8之间的数,5+8=13删掉8-13之间的数,8+13=21删掉13-21之间的数
得到:1,2,3,5,8,13,21
所以打表删除的数为:
a[30]={0,0,0,0,1,1,2,3,3,4,5,6,7,7,8,9,10,11,12,13,14};
之后直接输出就行

#include<stdio.h>
int main()
{
    int i,n,t,a[30]={0,0,0,0,1,1,2,3,3,4,5,6,7,7,8,9,10,11,12,13,14};
    scanf("%d",&t);
    for(i=1;i<=t;i++)
    {
        scanf("%d",&n);
        printf("Case #%d: %d\n",i,a[n]);
     } 
    return 0;
}

也有人用队列模拟

#include<iostream>  
#include<cstdio>  
#include<cstring>  
#include<queue>  
using namespace std;  
int main()  
{  
    queue<int>que;  
    int a[100];  
    a[0]=a[1]=a[2]=a[3]=0;  
    que.push(3);  
    que.push(2);  
    int n,m,k;  
    int ans=0;  
    k=4;  
    while(k<=20)  
    {  
        n=que.front();  
        que.pop();  
        m=que.front();  
        if(n+m>k)  
        {  
            ans++;  
            que.push(n);  
            a[k]=ans;  
        }  
        else  
        {  
            que.push(k);  
            a[k]=ans;  
        }  
        k++;  
    }  
    int p=1;  
    scanf("%d",&n);  
    while(n--)  
    {  
        scanf("%d",&m);  
        printf("Case #%d: ",p);  
        printf("%d\n",a[m]);  
        p++;  
    }  
    return 0;  
}  
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值