hdu 5914 Triangle 斐波那契

Triangle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 892    Accepted Submission(s): 486


Problem Description
Mr. Frog has n sticks, whose lengths are 1,2, 3 n respectively. Wallice is a bad man, so he does not want Mr. Frog to form a triangle with three of the sticks here. He decides to steal some sticks! Output the minimal number of sticks he should steal so that Mr. Frog cannot form a triangle with
any three of the remaining sticks.
 

Input
The first line contains only one integer T ( T20 ), which indicates the number of test cases. 

For each test case, there is only one line describing the given integer n ( 1n20 ).
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of sticks Wallice should steal.
 

Sample Input
  
  
3 4 5 6
 

Sample Output
  
  
Case #1: 1 Case #2: 1 Case #3: 2

1到n的长度的木棍去掉多少根可以所有棍子组不成三角形,明显斐波那契数列规律(两边之和大于第三边)或者打表。

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int F[40];
int ans[21];

int main()
{
    int i,j,T,n;


    ans[1]=ans[2]=ans[3]=0;
    ans[4]=ans[5]=1;
    ans[6]=2;
    ans[7]=3;
    ans[8]=3;
    for (i=9;i<13;i++)
    {
        ans[i]=ans[i-1]+1;
    }
    ans[13]=ans[12];
    for (i=14;i<=20;i++)
        ans[i]=ans[i-1]+1;
    int cas=1;
    scanf("%d",&T);
    while (T--)
    {
        scanf("%d",&n);
        printf("Case #%d: %d\n",cas++,ans[n]);

    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值