hdu 2680 Choose the best route【dijstra+反向建图】

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15494    Accepted Submission(s): 5027


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
  
  
1 -1
 

Author
dandelion

题意:给出顶点数和路径总数及要到达的终点,再给出可以到达终点的多个起点,输出这些起点中到终点的最短路径。

思路:如果找每个起点到终点的距离,最后比较出最小值,会tle(亲测有效),正解思路是反向建图,把题目所给的终点当作起点,多个起点当作终点,用一次dijstra求起点到每个顶点的最短路径,最后遍历查找起点到每个终点的路径的最短路。

看了别人的题解才知道,还有一个地方比较坑,同一路径,取权值最小的边,不过平时自己就习惯了判断自重边,反正也不影响结果,想不到这次避开了这个坑点。

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
#define N 1100
int w[N][N],dis[N],book[N],num[N];
int main()
{
     int n,m,s,t1,t2,t3,ans,min1,u,x,i,j;
     while(scanf("%d%d%d",&n,&m,&s)!=EOF)
     {
         for(i = 0; i <= n; i ++)
             for(j = 0; j <= n; j ++)
                     w[i][j] = inf;
        for(i = 1; i <= m; i ++)
        {
            scanf("%d%d%d",&t1,&t2,&t3);
            if(t3 < w[t2][t1])//判断自重边 
                w[t2][t1] = t3;//反向建图 
        }
         scanf("%d",&x);
         for(i = 1; i <= x; i ++)
             scanf("%d",&num[i]);
         memset(book,0,sizeof(book));
         for(i = 1; i <= n; i ++)
             dis[i] = w[s][i];
         book[s] = 1;
         for(i = 1; i < n; i ++)
         {
             min1 = inf;
             for(j = 1; j <= n; j ++)
                 if(!book[j]&&dis[j]<min1)
                 {
                     min1 = dis[j];
                     u = j;
                 }
             book[u] = 1;
             for(j = 1; j <= n; j ++)
                 if(!book[j]&&dis[j] > dis[u]+w[u][j])
                     dis[j] = dis[u]+w[u][j];
         }
         ans = inf;
         for(i = 1; i <= x; i ++)
            ans = min(ans,dis[num[i]]);//取反转图后起点到多个终点的最小权值 
        if(ans == inf)
             printf("-1\n");
         else
             printf("%d\n",ans);
 }
 return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值