CF665B Shopping

CF665B Shopping

题目描述

Ayush is a cashier at the shopping center. Recently his department has started a ''click and collect" service which allows users to shop online.

The store contains $ k $ items. $ n $ customers have already used the above service. Each user paid for $ m $ items. Let $ a_{ij} $ denote the $ j $ -th item in the $ i $ -th person’s order.

Due to the space limitations all the items are arranged in one single row. When Ayush receives the $ i $ -th order he will find one by one all the items $ a_{ij} $ ( $ 1<=j<=m $ ) in the row. Let $ pos(x) $ denote the position of the item $ x $ in the row at the moment of its collection. Then Ayush takes time equal to $ pos(a_{i1})+pos(a_{i2})+…+pos(a_{im}) $ for the $ i $ -th customer.

When Ayush accesses the $ x $ -th element he keeps a new stock in the front of the row and takes away the $ x $ -th element. Thus the values are updating.

Your task is to calculate the total time it takes for Ayush to process all the orders.

You can assume that the market has endless stock.

输入格式

The first line contains three integers n n n , m m m and k k k ( 1 ≤ n , k ≤ 100 , 1 ≤ m ≤ k 1\le n,k\le 100,1\le m\le k 1n,k100,1mk ) — the number of users, the number of items each user wants to buy and the total number of items at the market.

The next line contains k k k distinct integers p l p_{l} pl ( 1 < = p l < = k 1<=p_{l}<=k 1<=pl<=k ) denoting the initial positions of the items in the store. The items are numbered with integers from 1 1 1 to k k k .

Each of the next n n n lines contains m m m distinct integers a i j a_{ij} aij ( 1 < = a i j < = k 1<=a_{ij}<=k 1<=aij<=k ) — the order of the i i i -th person.

输出格式

Print the only integer $ t $ — the total time needed for Ayush to process all the orders.

输入输出样例

样例输入1
2 2 5
3 4 1 2 5
1 5
3 1
样例输出1
14

说明/提示

Customer 1 1 1 wants the items 1 1 1 and 5 5 5 .

p o s ( 1 ) = 3 pos(1)=3 pos(1)=3 , so the new positions are: [ 1 , 3 , 4 , 2 , 5 ] [1,3,4,2,5] [1,3,4,2,5] .

p o s ( 5 ) = 5 pos(5)=5 pos(5)=5 , so the new positions are: [ 5 , 1 , 3 , 4 , 2 ] [5,1,3,4,2] [5,1,3,4,2] .

Time taken for the first customer is 3 + 5 = 8 3+5=8 3+5=8 .

Customer 2 2 2 wants the items 3 3 3 and 1 1 1 .

p o s ( 3 ) = 3 pos(3)=3 pos(3)=3 , so the new positions are: [ 3 , 5 , 1 , 4 , 2 ] [3,5,1,4,2] [3,5,1,4,2] .

p o s ( 1 ) = 3 pos(1)=3 pos(1)=3 , so the new positions are: [ 1 , 3 , 5 , 4 , 2 ] [1,3,5,4,2] [1,3,5,4,2] .

Time taken for the second customer is 3 + 3 = 6 3+3=6 3+3=6 .

Total time is 8 + 6 = 14 8+6=14 8+6=14 .

Formally p o s ( x ) pos(x) pos(x) is the index of x x x in the current row.

思路

题上首先给了三个数 n , m , k n,m,k n,m,k,然后在第二行里给出了 k k k 个数,然后又 n × m n\times m n×m 个操作,代表每一次把这个操作的数移动到第一位,其他的往后推,每次移动的时候有一个权值(从第一个数到第这个数的相差的位置数),问的是所有权值的和,数据量不大,直接模拟就好。

看到楼上用的 vector,我这里用数组。

Code

#include <bits/stdc++.h>
using namespace std;

int main()
{
	int n, m, k, x, ans = 0, a[105];
	scanf("%d %d %d", &n, &m, &k);
	for (register int i(1); i <= k; ++i)
		scanf("%d", &a[i]);
	for (register int i(1); i <= n * m; ++i)
	{
		scanf("%d", &x);
		register int j, l;
		for (j = 1; j <= k; ++j)
			if (a[j] == x)
				break;
		ans += j;
		for (l = j; l >= 2; --l)
			a[l] = a[l - 1];
		a[1] = x;
	}
	printf("%d\n", ans);
	return 0;
}

广告

绿树公司 - 官方网站:https://wangping-lvshu.github.io/LvshuNew/

绿树智能 - 官方网站:https://wangping-lvshu.github.io/LvshuZhineng/

(现在使用,人人均可获得300元大奖)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

lvshu · 绿树

非常感谢您的搭讪

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值