poj 2992 Divisor

题目是求c(n,k)的因子的个数,n,k的的取值范围小于等于431.

如果暴力的绝对的超时,我都tlm了三次。

我的思路是n=p1^e1*p2^e2*.......pk^ek;把n!化成素数的乘积,然后利用公式才c(n,k)=n*(n-1)*(n-2)*...(n-m+1)/k*(k-1)*(k-2)*...2*1;

约分后得到s=p1^a1*p2*a2.....ps^as,那么因子的个数是(a1+1)*(a2+1)*(a3+1).....*(as+1).结果还是超时了。然后参考了别人的思想做了一下优化:

思路:一个数num的约数个数为cnt,将num质因数分化,得num = p1^a1 * p2^a2 * p3^a3 * ……*pn^an.
则约数个数cnt = (a1 + 1) * (a2 + 1) * (a3 + 1) * …… *(an + 1).
C[n][k] = n ! / ((n - k) ! * k !).
cal(n, k) 函数求出 n! 时能分化出几个 k。
(1) 先预求 1 到 431 的素数表。
(2) 则C[n][k]中包含素数prime[i]的个数为ai = cal(n!, prime[i]) - cal((n - k)!, prime[i]) - cal(k!, prime[i])。

题目描述:

Description

Your task in this problem is to determine the number of divisors of Cnk. Just for fun -- or do you need any special reason for such a useful computation?

Input

The input consists of several instances. Each instance consists of a single line containing two integers n and k (0 ≤ k ≤ n ≤ 431), separated by a single space.

Output

For each instance, output a line containing exactly one integer -- the number of distinct divisors of Cnk. For the input instances, this number does not exceed 263 - 1.

Sample Input

5 1
6 3
10 4

Sample Output

2
6
16
 
代码:
#include<iostream>
using namespace std;
typedef long long ll;
ll ct[450][450],flag[450];
ll n,m;
ll prime[100]={2,3,5,7,11,13,17,19,23,29,31,37,41,43,47,53,59,61,67,71,73,79,83,89,97,101,103,107,109,113,127,131,137,139,149,151,157,163,167,173,179,181,191,193,197,199,211,223,227,229,233,239,241,251,257,263,269,271,277,281,283,293,307,311,313,317,331,337,347,349,353,359,367,373,379,383,389,397,401,409,419,421,431,1000000};
void init()
{
     ll i,j,ret,s;
     for(i=2;i<=431;i++)
     {
       for(j=0;prime[j]<=i;j++)
       { 
         s=i;
         ret=0;
         while(s)
         {
           s=s/prime[j];
           ret+=s;
         }
         ct[i][prime[j]]=ret;
       }
   }
}        
int main()
{
    init();
    ll i,count,ret;
    while(scanf("%lld%lld",&n,&m)!=EOF)
    {
      count=1;
      for(i=0;prime[i]<=n;i++)
      {
        ret=ct[n][prime[i]]-ct[m][prime[i]]-ct[n-m][prime[i]];
        count*=(ret+1);
      }
      printf("%lld%\n",count);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值