HDU 1212 Big Number(简单的大数取模)

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1212

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6037    Accepted Submission(s): 4226


Problem Description
As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case, you have to ouput the result of A mod B.
 

Sample Input
  
  
2 3 12 7 152455856554521 3250
 

Sample Output
  
  
2 5 1521


题意:求长度不大于1000的a模于b(b<=100000)。


解题思路:题目看似很难,其实这是一道很简单的大数求模。首先要先有数学知识:a,b同余有,a%m = b%m ;  (a±b)%m = (a%m±b%m)%m ;(a*b)%m = (a%m*b%m)%m 。所以:将大数转化为字符串处理,然后问题可以等价于各个位数上的分别取模。


<span style="font-size:18px;">#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
const int maxn=1010;
char a[maxn];
int m,b[maxn];
int gcd(char *a,int m)
{
    int len=strlen(a);
    for(int i=0;i<len;i++) b[i]=a[i]-'0';
    int ans=0;
    for(int i=0;i<len;i++)
    {
        ans=(ans*10+b[i])%m;
    }
    return ans;
}
int main()
{
    while(cin>>a>>m)
    {
        cout<<gcd(a,m)<<endl;
    }
    return 0;
}
</span>



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值