HDOJ 1016 Prime Ring Problem(dfs+回溯)

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33376    Accepted Submission(s): 14770


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

ac代码:
#include<stdio.h>
#include<string.h>
int n;
int num[20];
int v[20];
int check(int x)//判断素数
{
    for(int i=2;i<x;i++)
    if(x%i==0)
    return 0;
    return 1;
}
void dfs(int s)
{
    int i,j;
    if(s==n+1&&check(num[n]+num[1]))//最后一个数和第一个数的判断
    {
        for(i=1;i<=n-1;i++)
        {
            printf("%d ",num[i]);
        }
        printf("%d\n",num[n]);//这题坑了两下,杭电输出真心严
        return;
    }
    for(j=2;j<=n;j++)
    {
        if(check(j+num[s-1])&&v[j]==0)
        {
            v[j]=1;
            num[s]=j;
            dfs(s+1);
            v[j]=0;//回溯
        }
    }
}
int main()
{
    int i,m=1;
    while(scanf("%d",&n)!=EOF)
    {
        memset(v,0,sizeof(v));
        num[1]=1;
        printf("Case %d:\n",m++);
        dfs(2);
        printf("\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值