HDOJ 1509 Windows Message Queue (简单优先队列 )

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4360    Accepted Submission(s): 1728


Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
 

Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
 

Sample Input
  
  
GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET
 

Sample Output
  
  
EMPTY QUEUE! msg2 10 msg1 10 EMPTY QUEUE!
 


ac代码:
#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
#include<algorithm>
using namespace std;
struct s
{
	char c[101];
	int x;
	int y;
	int n;
	bool friend operator<(s a,s b)
	{
		if(a.y==b.y)//如果优先级相同,就谁先进去谁先出来,所以定义一个n作为顺序
		return a.n>b.n;
		else
		return a.y>b.y;
	}
};
int main()
{
	char str[10];
	priority_queue<s>q;//把队列定义在外面会TLE
	int num=0;
	s d;
	while(scanf("%s",str)!=EOF)
	{
		if(strcmp(str,"PUT")==0)
		{
			scanf("%s %d %d\n",d.c,&d.x,&d.y);
			d.n=++num;
			q.push(d);
		}
		else
		{
			if(!q.empty())
			{
			  d=q.top();
			  printf("%s %d\n",d.c,d.x);
			  q.pop();
		    }
		    else
		    printf("EMPTY QUEUE!\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值