POJ 3723 Conscription(最小生成树--kruskul)

Conscription
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9310 Accepted: 3289

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.

1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223




刚开始想着用prime做,但是会爆,就用kruskul,对边权值进行排列,从最大的开始取
ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 100010
#define INF 0xfffffff
#define min(a,b) (a>b?b:a)
using namespace std;
int sum;
int pri[MAXN];
struct s
{
	int a;
	int b;
	int cost;
}dis[MAXN];
bool cmp(s A,s B)
{
	return A.cost>B.cost;
}
int find(int x)
{
	int r=x;
	while(r!=pri[r])
	r=pri[r];
	int i=x,j;
	while(i!=r)
	{
		j=pri[i];
		pri[i]=r;
		i=j;
	}
	return r;
}
void connect(int xx,int yy,int num)
{
	int nx=find(xx);
	int ny=find(yy);
	if(nx!=ny)
	{
		pri[nx]=pri[ny];
		sum-=num;
	}
}
int main()
{
	int t,n,m,q,i,c,d,e;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d",&n,&m,&q);
		for(i=0;i<n+m;i++)
		pri[i]=i;
		sum=(n+m)*10000;
		for(i=0;i<q;i++)
		{
			scanf("%d%d%d",&c,&d,&e);
			dis[i].a=c;
			dis[i].b=d+n;//人数为n+m个,所以男生数目编号都要加上女生的数目
			dis[i].cost=e;
		}
		sort(dis,dis+q,cmp);
		for(i=0;i<q;i++)
		{
			connect(dis[i].a,dis[i].b,dis[i].cost);
		}
		printf("%d\n",sum);
	}
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值