HDOJ 4324 Triangle LOVE(拓扑排序)

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3548    Accepted Submission(s): 1384


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No 判断是否存在回路即可。 ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define INF 0x7fffffff
#define MAXN 2001
#define max(a,b) a>b?a:b
#define min(a,b) a>b?b:a
using namespace std;
int pri[MAXN][MAXN];
int v[MAXN];
char num[MAXN][MAXN];
int n,m;
int main()
{
	int i,j,k,t,bz;
	int cas=0;
	scanf("%d",&t);
	while(t--)
	{
		bz=0;
		scanf("%d",&n);
		memset(pri,0,sizeof(pri));
		memset(v,0,sizeof(v));
		for(i=0;i<n;i++)
		{
			scanf("%s",num[i]);
			for(j=0;j<n;j++)
			{
				if(num[i][j]=='1')
				{
					pri[i+1][j+1]=1;
					v[j+1]++;
				}
			}
		}
		for(i=1;i<=n;i++)
		{
			k=0;
			for(j=1;j<=n;j++)
			{
				if(v[j]==0)
				{
					k=j;
				    break;
			    }
			}
			if(k==0)
			{
				bz=1;
				break;
			}
			else
			{
				v[k]--;
				for(j=1;j<=n;j++)
				{
					if(pri[k][j]==1)
					v[j]--;
			    }
		    }
		}
		printf("Case #%d: ",++cas);
		if(bz==0)
		printf("No\n");
		else
		printf("Yes\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值