HDOJ 2824 The Euler function (欧拉函数打表)

The Euler function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4658    Accepted Submission(s): 1953


Problem Description
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
 

Input
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
 

Output
Output the result of (a)+ (a+1)+....+ (b)
 

Sample Input
  
  
3 100
 

Sample Output
  
  
3042
 

题意:求a到b之间的欧拉数之和

思路:暴力肯定超时,300w的数据量太大了,需要技巧打表

ac代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define MAXN 3000001
#define MAX(a,b) a>b?a:b
#define LL long long
#define fab(a) ((a)>0?(a):-(a))
using namespace std;
LL ans[MAXN];
void db()
{
	memset(ans,0,sizeof(ans));
	ans[1]=1;
	int i,j;
	for(i=2;i<=MAXN;i++)
	{
		if(!ans[i])
		{
			for(j=i;j<=MAXN;j+=i)
			{
				if(!ans[j])
				ans[j]=j;
				ans[j]=ans[j]/i*(i-1);
		    }
		}
	}
}
int main()
{
	int i,a,b;
	db();
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		LL sum=0;
		for(i=a;i<=b;i++)
		sum+=ans[i];
		printf("%lld\n",sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值