POJ 3070 Fibonacci (矩阵快速幂求fibonacci)

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11439 Accepted: 8134

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875



ac代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 1000000000
#define MOD 10000
#define LL long long
#define INF 0xfffffff
#define fab(a)(a)>0?(a):(-a)
using namespace std; 
int fib(int b)
{
	int t[2][2];
	int ans[2][2];
	int a[2][2];
	ans[0][0]=ans[1][1]=1,ans[0][1]=ans[1][0]=0;
	a[0][0]=a[0][1]=a[1][0]=1,a[1][1]=0;
	int i,j,k;
	while(b)
	{
		if(b%2)
		{
			for(i=0;i<2;i++)
			for(j=0;j<2;j++)
			t[i][j]=ans[i][j];
			ans[0][0]=ans[1][1]=ans[0][1]=ans[1][0]=0;//每次使用完都要清零  因为是累加
			for(i=0;i<2;i++)
			{
				for(j=0;j<2;j++)
				{
					for(k=0;k<2;k++)
					{
						ans[i][j]=(ans[i][j]+(t[i][k]*a[k][j]))%MOD;
					}
				}
			}
		}
		for(i=0;i<2;i++)
		for(j=0;j<2;j++)
		t[i][j]=a[i][j];
		a[0][0]=a[1][1]=a[0][1]=a[1][0]=0;//每次使用完都要清零  因为是累加
		for(i=0;i<2;i++)
		{
			for(j=0;j<2;j++)
			{
				for(k=0;k<2;k++)
				{
					a[i][j]=(a[i][j]+(t[i][k]*t[k][j]))%MOD;
				}
			}
		}
		b/=2;
	}
	return ans[0][1];
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==-1)
		break;
		printf("%d\n",fib(n));
	}
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值