LightOJ 1410 - Consistent Verdicts (判断去重)

题目描述了在二维平面上有N个人,每个人持有一支枪,他们依次开火且不会同时听到两声枪响。所有人听力相同,能够听到在一定范围内的枪声。每个参与者报告他们听到的枪声数量,任务是判断这些报告是否可能一致。例如,给定的坐标情况中,(1, 2), (3, 1), (5, 1), (6, 3), (1, 5) 五个人,若报告分别为 1, 1, 1, 2, 1,则不一致,因为如果第4个人听到2声,其他人应该至少听到2声。而 (1, 2, 2, 1, 0) 和 (2, 2, 2, 1, 1) 是一致的。输入包含多个测试案例,每个案例给出人员坐标,输出每个案例的一致判决总数。" 82867476,3030799,RecyclerView瀑布流布局实践与优化,"['Android开发', 'UI设计', 'RecyclerView', '布局管理']
摘要由CSDN通过智能技术生成

1410 - Consistent Verdicts


Description

In a 2D plane N persons are standing and each of them has a gun in his hand. The plane is so big that the persons can be considered as points and their locations are given as Cartesian coordinates. Each of the N persons fire the gun in his hand exactly once and no two of them fire at the same or similar time (the sound of two gun shots are never heard at the same time by anyone so no sound is missed due to concurrency). The hearing ability of all these persons is exactly same. That means if one person can hear a sound at distance R1, so can every other person and if one person cannot hear a sound at distance R2 the other N-1 persons cannot hear a sound at distance R2 as well.

The N persons are numbered from 1 to N. After all the guns are fired, all of them are asked how many gun shots they have heard (not including their own shot) and they give their verdict. It is not possible for you to determine whether their verdicts are true but it is possible for you to judge if their verdicts are consistent. For example, look at the figure above. There are five persons and their coordinates are (1, 2), (3, 1), (5, 1), (6, 3) and (1, 5) and they are numbered as 1, 2, 3, 4 and 5 respectively. After all five of them have shot their guns, you ask them how many shots each of them have heard. Now if there response is 1, 1, 1, 2 and 1 respectively then you can represent it as (1, 1, 1, 2, 1). But this is an inconsistent verdict because if person 4 hears 2 shots then he must have heard the shot fired by person 2, then obviously person 2 must have heard the shot fired by person 1, 3 and 4 (person 1 and 3 are nearer to person 2 than person 4). But their opinions show that Person 2 says that he has heard only 1 shot. On the other hand (1, 2, 2, 1, 0) is a consistent verdict for this scenario so is (2, 2, 2, 1, 1). In this scenario (5, 5, 5, 4, 4) is not a consistent verdict because a person can hear at most 4 shots.

Given the locations of N persons, your job is to find the total number of different consistent verdicts for that scenario. Two verdicts are different if opinion of at least one person is different.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing a positive integer N (1 ≤ N ≤ 700). Each of the next N lines contains two integers xi yi (0 ≤ xi, yi ≤ 30000) denoting a co-ordinate of a person. Assume that all the co-ordinates are distinct.

Output

For each case, print the case number and the total number of different consistent verdicts for the given scenario.

Sample Input

2

3

1 1

2 2

4 4

2

1 1

5 5

Sample Output

Case 1: 4

Case 2: 2



把每两个点之间的距离求出来,然后去重然后+1即为所求

ac代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 1010000
#define MOD 1000000007
#define LL long long
#define INF 0xfffffff
#define fab(a)(a)>0?(a):(-a)
using namespace std;
struct s
{
	int x;
	int y;
}a[MAXN];
double dis[MAXN];
double fun(int aa,int bb)
{
	return sqrt((a[aa].x-a[bb].x)*(a[aa].x-a[bb].x)+(a[aa].y-a[bb].y)*(a[aa].y-a[bb].y));
}
int main()
{
	int t,i,n,j;
	int cas=0;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		scanf("%d%d",&a[i].x,&a[i].y);
		int k=0;
		for(i=1;i<=n;i++)
		{
			for(j=i+1;j<=n;j++)
			{
				dis[k++]=fun(i,j);
			}
		}
		sort(dis,dis+k);
		double v=dis[0];
		int ans=1;
		for(i=1;i<k;i++)
		{
			if(dis[i]!=v)
			ans++,v=dis[i];
		}
		printf("Case %d: %d\n",++cas,ans+1);
	}
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值