HDOJ 4126 Bazinga (字符串预处理)

Bazinga

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 946    Accepted Submission(s): 334


Problem Description
Ladies and gentlemen, please sit up straight.
Don't tilt your head. I'm serious.

For n given strings S1,S2,,Sn , labelled from 1 to n , you should find the largest i (1in) such that there exists an integer j (1j<i) and Sj is not a substring of Si .

A substring of a string Si is another string that occurs in Si . For example, ``ruiz" is a substring of ``ruizhang", and ``rzhang" is not a substring of ``ruizhang".
 

Input
The first line contains an integer t (1t50) which is the number of test cases.
For each test case, the first line is the positive integer n (1n500) and in the following n lines list are the strings S1,S2,,Sn .
All strings are given in lower-case letters and strings are no longer than 2000 letters.
 

Output
For each test case, output the largest label you get. If it does not exist, output 1 .
 

Sample Input
  
  
4 5 ab abc zabc abcd zabcd 4 you lovinyou aboutlovinyou allaboutlovinyou 5 de def abcd abcde abcdef 3 a ba ccc
 

Sample Output
  
  
Case #1: 4 Case #2: -1 Case #3: 4 Case #4: 3
 


题意:给n个字符串,求最大的i使得存在s[j]不是s[i]的子串,其中j<i


思路:暴力写肯定超时,一眼看去肯定有人要用kmp了,但是c++里有一个strstr函数并不比kmp慢,所以可以直接

使用,先预处理每个字符串相邻的串,如果s[j]是s[j+1]的子串,那么检查遍历到i的时候可以直接跳过,直接去判断s[j+1],因为如果s[j+1]为s[i]的子串,那么s[j]也一定为s[i]的子串,倒着遍历i,符合情况直接退出,这样更加省时。。

ac代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<algorithm>
#define max(a,b) a>b?a:b
#define MAXN 1010
#define INF 0xfffffff
using namespace std;
char s[550][2100];
int v[550];
int main()
{
	int t,i,j,n;
	int cas=0;
	scanf("%d",&t);
    while(t--)
    {
    	memset(v,0,sizeof(v));
    	scanf("%d",&n);
    	for(i=1;i<=n;i++)
    	scanf("%s",s[i]);
    	for(i=1;i<n;i++)
    	{
    		if(strstr(s[i+1],s[i]))//预处理字符串
    		v[i]=1;
		}
		int ans=0;
		for(i=n;i>=1;i--)
		{
			for(j=1;j<i;j++)
			{
				if(v[j])
				continue;
				else
				{
					if(!strstr(s[i],s[j]))
					{
					    ans=i;
					    break;
				    }
				}
			}
			if(ans)
			break;
		}
		printf("Case #%d: ",++cas);
		printf(ans==0?"-1\n":"%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值