POJ 3335 Rotating Scoreboard (半平面交判断)

Rotating Scoreboard
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6190 Accepted: 2447

Description

This year, ACM/ICPC World finals will be held in a hall in form of a simple polygon. The coaches and spectators are seated along the edges of the polygon. We want to place a rotating scoreboard somewhere in the hall such that a spectator sitting anywhere on the boundary of the hall can view the scoreboard (i.e., his line of sight is not blocked by a wall). Note that if the line of sight of a spectator is tangent to the polygon boundary (either in a vertex or in an edge), he can still view the scoreboard. You may view spectator's seats as points along the boundary of the simple polygon, and consider the scoreboard as a point as well. Your program is given the corners of the hall (the vertices of the polygon), and must check if there is a location for the scoreboard (a point inside the polygon) such that the scoreboard can be viewed from any point on the edges of the polygon.

Input

The first number in the input line, T is the number of test cases. Each test case is specified on a single line of input in the form n x1 y1 x2 y2 ... xn yn where n (3 ≤ n ≤ 100) is the number of vertices in the polygon, and the pair of integers xi yi sequence specify the vertices of the polygon sorted in order.

Output

The output contains T lines, each corresponding to an input test case in that order. The output line contains either YES or NO depending on whether the scoreboard can be placed inside the hall conforming to the problem conditions.

Sample Input

2
4 0 0 0 1 1 1 1 0
8 0 0  0 2  1 2  1 1  2 1  2 2  3 2  3 0

Sample Output

YES
NO


第一道题,并不需要调顺序

ac代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 60001
#define LL long long
#define INF 0xfffffff
#define mem(aa) memset(aa,0,sizeof(aa))
#define PI acos(-1)
#define eps 1e-8
using namespace std;
struct s
{
	double x,y;
};
s list[MAXN],p[MAXN],q[MAXN];
double a,b,c;
int cnt,ccnt,n;
void getline(s x,s y)
{
	a=y.y-x.y;b=x.x-y.x;c=y.x*x.y-x.x*y.y;
}
s xlist(s x,s y)
{
	double u=fabs(a*x.x+b*x.y+c);
	double v=fabs(a*y.x+b*y.y+c);
	s k;
	k.x=(x.x*v+y.x*u)/(u+v);
	k.y=(x.y*v+y.y*u)/(u+v);
	return k;
}
void cut()
{
	ccnt=0;
	for(int i=1;i<=cnt;i++)
	{
		if(a*p[i].x+b*p[i].y+c>=0)
		q[++ccnt]=p[i];
		else
		{
			if(a*p[i-1].x+b*p[i-1].y+c>0)
			q[++ccnt]=xlist(p[i],p[i-1]);
			if(a*p[i+1].x+b*p[i+1].y+c>0)
			q[++ccnt]=xlist(p[i],p[i+1]);
		}
	}
	for(int i=1;i<=ccnt;i++)
	p[i]=q[i];
	p[ccnt+1]=q[1];p[0]=p[ccnt];
	cnt=ccnt;
}
void solve()
{
	int i;
	for(i=1;i<=n;i++)
	p[i]=list[i];
	p[n+1]=p[1];p[0]=p[n];
	cnt=n;
	for(i=1;i<=n;i++)
	{
		getline(list[i],list[i+1]);
		cut();
	}
}
int main()
{
	int t,i;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		scanf("%lf%lf",&list[i].x,&list[i].y);
		list[n+1]=list[1];
		solve();
		if(cnt>0)
		printf("YES\n");
		else
		printf("NO\n");
	}
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值