poj3335(半平面交)

Description

This year, ACM/ICPC World finals will be held in a hall in form of a simple polygon. The coaches and spectators are seated along the edges of the polygon. We want to place a rotating scoreboard somewhere in the hall such that a spectator sitting anywhere on the boundary of the hall can view the scoreboard (i.e., his line of sight is not blocked by a wall). Note that if the line of sight of a spectator is tangent to the polygon boundary (either in a vertex or in an edge), he can still view the scoreboard. You may view spectator’s seats as points along the boundary of the simple polygon, and consider the scoreboard as a point as well. Your program is given the corners of the hall (the vertices of the polygon), and must check if there is a location for the scoreboard (a point inside the polygon) such that the scoreboard can be viewed from any point on the edges of the polygon.

Input

The first number in the input line, T is the number of test cases. Each test case is specified on a single line of input in the form n x1 y1 x2 y2 … xn yn where n (3 ≤ n ≤ 100) is the number of vertices in the polygon, and the pair of integers xi yi sequence specify the vertices of the polygon sorted in order.

Output

The output contains T lines, each corresponding to an input test case in that order. The output line contains either YES or NO depending on whether the scoreboard can be placed inside the hall conforming to the problem conditions.

Sample Input
2
4 0 0 0 1 1 1 1 0
8 0 0 0 2 1 2 1 1 2 1 2 2 3 2 3 0

Sample Output
YES
NO

这里写代码片
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>

using namespace std;

const int N=300;
const double eps=1e-8;
int n,T,m;//m为新切割出来的多边形的顶点数 
struct node{
    double x,y;
    node (double xx=0,double yy=0)
    {
        x=xx;y=yy;
    }
}; 
node po[N],p[N],q[N]; q临时保存新切割的多边形,p保存新切割出的多边形
double a,b,c;

node operator +(const node &a,const node &b)
{
    return node(a.x+b.x,a.y+b.y);
}

node operator -(const node &a,const node &b)
{
    return node(a.x-b.x,a.y-b.y);
}
node operator *(const node &a,const double &b)
{
    return node(a.x*b,a.y*b);
}
node operator /(const node &a,const double &b)
{
    return node(a.x/b,a.y/b);
}

int dcmp(double x)
{
    if (fabs(x)<eps) return 0;
    else if (x>0) return 1;
    else return -1;
}

int getline(node x,node y)  //获取直线ax+by+c==0
{
    a=y.y-x.y;
    b=x.x-y.x;
    c=y.x*x.y-y.y*x.x;
}

node insert(node x,node y) //获取直线ax+by+c==0和点x和y所连直线的交点
{
    double u=fabs(a*x.x+b*x.y+c);
    double v=fabs(a*y.x+b*y.y+c);
    node ans;
    ans.x=(x.x*v+y.x*u)/(u+v);  //交叉相乘除以和 
    ans.y=(x.y*v+y.y*u)/(u+v);
    return ans;
}

void cut()
{
    int cutn=0,i;
    for (i=1;i<=m;i++)
    {
        if (a*p[i].x+b*p[i].y+c>=0)
        {
            q[++cutn]=p[i];   //所以一个点在直线右边的话,那么带入值就会大于等于0
        }
        else
        {
            if (a*p[i-1].x+b*p[i-1].y+c>0)  //该点不在多边形内,但是它和它相邻的点构成直线与
            {                               //ax+by+c==0所构成的交点可能在新切割出的多边形内,
                q[++cutn]=insert(p[i-1],p[i]);
            }
            if (a*p[i+1].x+b*p[i+1].y+c>0)
            {
                q[++cutn]=insert(p[i+1],p[i]);
            }
        }
    }
    for (i=1;i<=cutn;i++)
        p[i]=q[i];
    p[cutn+1]=p[1];
    p[0]=p[cutn];
    m=cutn;
}

void solve()
{
    for (int i=1;i<=n;i++) p[i]=po[i];
    po[n+1]=po[1];  //连起来 
    p[n+1]=p[1];
    p[0]=p[n];
    m=n;
    for (int i=1;i<n;i++)
    {
        getline(po[i],po[i+1]);//根据point[i]和point[i+1]确定直线ax+by+c==0
        cut();  //用直线ax+by+c==0切割多边形
    }
}

int main()
{
    scanf("%d",&T);
    while (T--)
    {
        scanf("%d",&n);
        for (int i=1;i<=n;i++)
           scanf("%lf%lf",&po[i].x,&po[i].y);
        solve();
        if (m==0) printf("NO\n");  //没有核 
        else printf("YES\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值