POJ 1852 Ants (贪心)

Ants
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 12949 Accepted: 5670

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

Source

Waterloo local 2004.09.19

题意:一根棍子,然后给你他的长度,还有n个蚂蚁所在的位置,蚂蚁走到最顶处会掉下来,问全部蚂蚁都掉下来的最长时间和最短时间

思路:裸贪心,在输入过程中,取M=max(M,max(a,len-a))为最长时间,mi=max(mi,min(a,len-a))为最短时间,至于为什么这么贪,模拟一下就行了

总结:写一下,模拟一下,1Y
ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<iostream>
#include<algorithm>
#define LL long long
#define INF 0xfffffff
#define MAXN 50000
#define mem(x) memset(x,0,sizeof(x))
using namespace std;
int main()
{
	int i,n,a;
	int t,len;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&len,&n);
		int M=-INF;
		int mi=-INF;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a);
			M=max(M,max(a,len-a));
			mi=max(mi,min(a,len-a));
		}
		printf("%d %d\n",mi,M);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值