HDOJ 3183 A Magic Lamp (贪心)

A Magic Lamp

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2516    Accepted Submission(s): 984


Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams.
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
 

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
 

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it.
 

Sample Input
  
  
178543 4 1000001 1 100001 2 12345 2 54321 2
 

Sample Output
  
  
13 1 0 123 321 题意:给出一个字符串,删去m个数字,然后使得删除后的数字组成的数最小,没有前缀0 思路:刚看可能会直接对字符进行排序,然后删去最大的数字,但是想了想就会发现是错误的, 例如:21345 2 如果按照上面的方法,最后结果是213,但是正确的确实134,所以就不是 那么的简单了,写出来会发现一个规律,当s[i]>s[i+1]时,s[i]是要删除的,然后贪心每删除一个 就标记停止重新删除,如果符合条件的数字少于需要删除的数字,那么直接倒着删除就行了,因为 此时的字符串已经排好了序,直接删除相差的就行了。 ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stack>
#include<iostream>
#include<algorithm>
#define fab(a) (a)>0?(a):(-a)
#define LL long long
#define MAXN 10010
#define INF 0xfffffff 
using namespace std;
char s[MAXN];
int v[MAXN];
int num[MAXN];
int main()
{
    int i,l,j;
    while(scanf("%s",s)!=EOF)
    {
        scanf("%d",&l);
        int len=strlen(s);
        for(i=0;i<len;i++)
        num[i]=s[i]-'0';
        memset(v,0,sizeof(v));
        int q=0;
        int k=l;
        while(k--)//贪心删除
        {
            for(i=0;i<len-1;i++)
            {
                if(!v[i])
                {
                    j=i+1;
                    while(v[j])//查找未标记的
                    j++;
                    if(num[i]>num[j])
                    {
                        v[i]=1,q++;//符合条件,标记停止
                        break;
                    }
                }
            }
        }
        int cnt=l-q;
        //printf("%d\n",cnt);
        for(i=len-1;i>=0;i--)//倒着寻找
        {
            if(!v[i]&&cnt)
            {
                v[i]=1;
                cnt--;
            }
        }
        int bz=0,o=0;
        for(i=0;i<len;i++)
        {
            if(!v[i])
            {
                if(s[i]!='0')
                bz=1;
                if(bz)
                printf("%c",s[i]),o++;
            }
        }
        if(o==0)
        printf("0");
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值