HDOJ 1069 Monkey and Banana (结构体LIS)

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10492    Accepted Submission(s): 5446


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 


题意:给你一些种类的木块,它可以随意翻转,一个木块上面只能放比他长宽都小的一个木块,问你他们能组成的最高高度

思路:将每种木块的各种放置方案都存起来,然后就是从上到下的一个最长单调上升子序列问题,只是这里的最长是高度最高,dp值存的就是高度了,不再是长度

总结:第一次忘了在过程中取最大值,WA了



ac代码:

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 101000
#define LL long long
#define ll __int64
#define INF 0xfffffff
#define mem(x) memset(x,0,sizeof(x))
#define PI acos(-1)
using namespace std;
struct s
{
	int x,y,z;
}a[MAXN];
int dp[2010];
bool cmp(s aa,s bb)
{
	if(aa.x==bb.x)
	return aa.y<bb.y;
	return aa.x<bb.x;
}
int main()
{
	int t,n,m,i,j;
	int cas=0;
	int x,y,z;
	while(scanf("%d",&n)!=EOF,n)
	{
		int cnt=0;
		for(i=0;i<n;i++)
		{
			scanf("%d%d%d",&x,&y,&z);
			a[cnt].x=x,a[cnt].y=y,a[cnt].z=z;cnt++;
			a[cnt].x=x,a[cnt].y=z,a[cnt].z=y;cnt++;
			a[cnt].x=y,a[cnt].y=z,a[cnt].z=x;cnt++;
			a[cnt].x=y,a[cnt].y=x,a[cnt].z=z;cnt++;
			a[cnt].x=z,a[cnt].y=x,a[cnt].z=y;cnt++;
			a[cnt].x=z,a[cnt].y=y,a[cnt].z=x;cnt++;
		}
		sort(a,a+cnt,cmp);
		int ans=-1;
		for(i=0;i<cnt;i++)
		{
			dp[i]=a[i].z;
			for(j=0;j<i;j++)
			{
				if(a[j].x<a[i].x&&a[j].y<a[i].y)
				{
					dp[i]=max(dp[i],dp[j]+a[i].z);
				}
			}
			ans=max(ans,dp[i]);
		}
		printf("Case %d: maximum height = ",++cas);
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值