HDOJ 1757 A Simple Math Problem (矩阵快速幂)

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3695    Accepted Submission(s): 2214


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
  
  
45 104
 



题意:题目不长,应该能看懂


思路:




ac代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 101000
#define LL long long
#define ll __int64
#define INF 0xfffffff
#define mem(x) memset(x,0,sizeof(x))
#define PI acos(-1)
using namespace std;
int ans[10][10];
int a[10][10];
int MOD;
void Matrix(int A[10][10],int B[10][10],int n)
{
	int T[10][10];
	mem(T);
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<n;j++)
		{
			for(int k=0;k<n;k++)
			{
				T[i][j]+=A[i][k]*B[k][j];
			}
			T[i][j]=T[i][j]%MOD;
		}
	}
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<n;j++)
		{
			A[i][j]=T[i][j];
		}
	}
}
void Matrixpow(int A[10][10],int n,int m)
{
	mem(ans);
	for(int i=0;i<n;i++)
	ans[i][i]=1;
	while(m)
	{
		if(m%2)
		Matrix(ans,A,n);
		Matrix(A,A,n);
		m/=2;
	}
}
int main()
{
	LL k;
	int num,i,j;
	while(scanf("%lld%d",&k,&MOD)!=EOF)
	{
		mem(a);
		for(i=0;i<10;i++)
		{
			scanf("%d",&num);
			a[0][i]=num;
			a[i+1][i]=1;
		}
		if(k<10)//特判
		{
			printf("%d\n",k%MOD);
			continue;
		}
		Matrixpow(a,10,k-9);
		int sum=0;
		for(i=0;i<10;i++)
		{
			sum+=ans[0][i]*(9-i);
			sum=sum%MOD;
		}
		printf("%d\n",sum);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值