UVA1586 Molar mass

Description

Download as PDF

An organic compound is any member of a large class of chemical compounds whose molecules contain carbon. The molar mass of an organic compound is the mass of one mole of the organic compound. The molar mass of an organic compound can be computed from the standard atomic weights of the elements.


When an organic compound is given as a molecular formula, Dr. CHON wants to find its molar mass. A molecular formula, such as C3H4O3 , identifies each constituent element by its chemical symbol and indicates the number of atoms of each element found in each discrete molecule of that compound. If a molecule contains more than one atom of a particular element, this quantity is indicated using a subscript after the chemical symbol.

In this problem, we assume that the molecular formula is represented by only four elements, `C' (Carbon), `H' (Hydrogen), `O' (Oxygen), and `N' (Nitrogen) without parentheses.

The following table shows that the standard atomic weights for `C', `H', `O', and `N'.

Atomic NameCarbonHydrogenOxygenNitrogen
Standard Atomic Weight12.01 g/mol1.008 g/mol16.00 g/mol14.01 g/mol


For example, the molar mass of a molecular formula C6H5OH is 94.108 g/mol which is computed by 6 × (12.01 g/mol) + 6 × (1.008 g/mol) + 1 × (16.00 g/mol).

Given a molecular formula, write a program to compute the molar mass of the formula.

Input 

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case is given in a single line, which contains a molecular formula as a string. The chemical symbol is given by a capital letter and the length of the string is greater than 0 and less than 80. The quantity number n which is represented after the chemical symbol would be omitted when the number is 1 (2<=n<=99) .

Output 

Your program is to write to standard output. Print exactly one line for each test case. The line should contain the molar mass of the given molecular formula.

Sample Input 

4 
C 
C6H5OH 
NH2CH2COOH 
C12H22O11

Sample Output 

12.010 
94.108 
75.070 
342.296
 
 
这道题最难得地方应该就是求出每个原子的个数,由题意可知每个原子个数不会超过99,所以只会是一位数或者两位数,所以遍历字符串每个字符,如果该字符后面是数字,则该原子个数就是后面的数字,若该字符后面不是数字,那么该原子个数就为1。
ac代码如下:
 
 
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
    int t,i,n;
    double sum;
    char s[85];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",s);
        sum=0;
        for(i=0;i<strlen(s);i++)
        {
            if(s[i+1]>='0'&&s[i+1]<='9')
            {
                if(s[i+2]>='0'&&s[i+2]<='9')
                {
                    n=(s[i+1]-'0')*10+(s[i+2]-'0');
                }
                else
                    n=s[i+1]-'0';
            }
            else
                n=1;
            if(s[i]=='C')
                sum+=12.01*n;
            else if(s[i]=='H')
                sum+=1.008*n;
            else if(s[i]=='O')
                sum+=16.00*n;
            else if(s[i]=='N')
                sum+=14.01*n;
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值