UVA156-Ananagrams

Description

Download as PDF

Most crossword puzzle fans are used to anagrams--groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.

Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged'' at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

Sample input

ladder came tape soon leader acme RIDE lone Dreis peat
 ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#

Sample output

Disk
NotE
derail
drIed
eye
ladder
soon
 
 
先建一个二维字符数组word[100][25]储存每个单词,输入时遇到"#"结束;
然后依次将每个单词与其他单词比较,建立两个字符数组,一个储存每个字符已换为小写字母并且已经排序过的比较单词,一个储存每个字符已换为小写并且已经排序过的被计较单词,若两个单词相同,则n++,最后每个单词与其他单词比较过了,n仍等于0时,则将这个单词原本的单词word[j]放入另外一个字符数组print。。。最后将print排序,输出即可。。。说的太乱了,简而言之就是将每个单词每个字符变小写然后排序,再依次比较。。。
 
 
代码如下:
 
 
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <ctype.h>
char word[100][25];
char print[100][25];
int cmp(const void* a, const void* b)
{
      return strcmp((char*)a,(char*)b);
 }
int main()
{
    int i=0,j,k,p,n,count=0;;
    char tmp[25],c[25];
    while(scanf("%s",&word[i])!=-1&&word[i][0]!='#')
    {
        i++;
    }
    for(j=0;j<i;j++)
    {
        n=0;
        for(k=0;k<strlen(word[j]);k++)
        {
        	if(word[j][k]>='A'&&word[j][k]<='Z')
            	tmp[k]=tolower(word[j][k]);
            else
            	tmp[k]=word[j][k];
        }
        tmp[k]='\0';
        qsort(tmp,strlen(tmp),sizeof(tmp[0]),cmp);
        for(k=0;k<i;k++)
        {
        	if(k==j)
				continue; 
            for(p=0;p<strlen(word[k]);p++)
            {
            	if(word[k][p]>='A'&&word[k][p]<='Z')
                	c[p]=tolower(word[k][p]);
                else
                	c[p]=word[k][p];
            }
            c[p]='\0';
            qsort(c,strlen(c),sizeof(c[0]),cmp);
            if(strcmp(tmp,c)==0)
            {
                n++;break;
            }
        }
        if(n==0)
        {
            strcpy(print[count++],word[j]);
        }
    }
    qsort(print,count,sizeof(print[0]),cmp);
    for(i=0;i<count;i++)
    {
        printf("%s\n",print[i]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值