L2-008. 最长对称子串
时间限制
100 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越
对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定"Is PAT&TAP symmetric?",最长对称子串为"s PAT&TAP s",于是你应该输出11。
输入格式:
输入在一行中给出长度不超过1000的非空字符串。
输出格式:
在一行中输出最长对称子串的长度。
输入样例:Is PAT&TAP symmetric?输出样例:
11
代码如下:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dp[1002][1002];
char s[1001];
int main()
{
gets(s);
int len = strlen(s), max = 1;
memset(dp, 0, sizeof(dp));
for(int i=0; i<len; ++i)
dp[i][i] = dp[i+1][i] = 1;
for(int i=1; i<=len; ++i)
for(int j=0; j+i<len; ++j)
if(s[j]==s[j+i] && dp[j+1][j+i-1])
{
dp[j][j+i]=1;
if(i+1>max)
max=i+1;
}
cout<<max<<endl;
return 0;
}