POJ-2395 Out of Hay

Out of Hay

Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 13609

 

Accepted: 5270

Description

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1. 

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry. 

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

Input

* Line 1: Two space-separated integers, N and M. 

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

Output

* Line 1: A single integer that is the length of the longest road required to be traversed.

Sample Input

3 3
1 2 23
2 3 1000
1 3 43

Sample Output

43

Hint

OUTPUT DETAILS: 

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.

题解:有n个农场,贝西在1号农场,要访问其他n-1个农场,给出m条路,a  b  c表示a农场到b农场路程为c(两个农场间可能有多条路)。贝西会挑选最短的路径来访问完这n-1个农场。 问在此过程中贝西会经过的最大边是多大?贝西要遍历,每一个农场,是最小生成树问题,我们在求出最短路径时,记录下最大边就可以。

kruskal算法:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
int N,M;
int pre[2010];
struct node{
	int star;
	int end;
	int dis;
}s[20010];
bool cmp(node a,node b){
	return a.dis<b.dis;
}
void getMap(){
	int a,b,c;
	for(int i=1;i<=M;i++){
		cin>>a>>b>>c;
		s[i].star=a;
		s[i].end=b;
		s[i].dis=c;
	}
}                                                                                                                                                                                                                                                                          
void init(){
	for(int i=1;i<=N;i++){
		pre[i]=i;
	}
}
int find(int x){
    if(pre[x]==x)
	   return x;
	return pre[x]=find(pre[x]);	
}
void mar(int x,int y){
	int xx=find(x);
	int yy=find(y);
	if(xx!=yy);
	pre[xx]=yy;
}
void kruskal(){
	int ac[2010];//用一个数组记录形成最小生成树时的所有路径,也可以用个flag记录最大边,不用记录。
	for(int i=0;i<2010;i++)//初始化数组,以后要排序,初始化是必要的
	ac[i]=INF;
	sort(s+1,s+M+1,cmp);
	long long ans=0;
	int num=0;
	for(int i=1;i<=M;i++){
		if(find(s[i].star)!=find(s[i].end)){
			mar(s[i].star,s[i].end);
			ans=ans+s[i].dis;
			ac[num]=s[i].dis;
			num++;
		}
		if(i==M&&num!=N-1) ans=-1;
	}
	sort(ac,ac+num);//排序,最大边在num-1处,即N-2处。
	cout<<ac[num-1]<<endl;
} 
using namespace std;
int main(){   
	while(cin>>N&&N){
	cin>>M;
	init();
    getMap();
	kruskal();
	}
}

prime算法:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define inf 0x3f3f3f3f
#define N 2002
#define M 10005
using namespace std;
int map[N][N],n,m,dis[M],vis[N],ans;
// A single integer 
//that is the length of the longest road required to be traversed.
//输出所有路径中的最长的路
int prim()
{
	ans=0;
	memset(vis,0,sizeof(vis));
	for(int i=1;i<=n;++i)
		dis[i]=map[1][i];
	vis[1]=1;
	for(int i=1;i<n;i++)
	{
		int minn=inf,k=-1;
		for(int j=1;j<=n;j++)
		{
			if(!vis[j]&&dis[j]<minn)
			{
				minn=dis[j];
				k=j;
			}
		}
		if(minn!=inf&&minn>ans)
			ans=minn;
		vis[k]=1;
		for(int u=1;u<=n;u++)
		{
			if(!vis[u]&&dis[u]>map[k][u])
				dis[u]=map[k][u];
		}
	}return ans;
}
 
int main()
{
	int a,b,c;
	cin>>n>>m;
	for(int i=1;i<=n;i++)
    {
		for(int j=1;j<=n;j++)
        {
            if(i==j)
                map[i][j]=0;
            else
                map[i][j]=map[j][i]=inf;
        }
    }
    while(m--)
    {
        scanf("%d%d%d",&a,&b,&c);
        if(map[a][b]>c)
            map[a][b]=map[b][a]=c;
    }
    cout<<prim()<<endl;
 
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值