POJ - 2395 Out of Hay

Out of Hay
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17481 Accepted: 6878

Description

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1. 

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry. 

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

Input

* Line 1: Two space-separated integers, N and M. 

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

Output

* Line 1: A single integer that is the length of the longest road required to be traversed.

Sample Input

3 3
1 2 23
2 3 1000
1 3 43

Sample Output

43


题意:

        给出n个农场和m条边,农场按1到n编号,现在有一人要从编号为1的农场出发到其他的农场去,求在这途中他最多需要携带的水的重量,注意他每到达一个农场,可以对水进行补给,且要使总共的路径长度最小。

题解:

   就是求最小生成树中的最长边。


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int pre[2005],n,m;
struct edge
{
    int u,v,w;
}e[10010];
bool cmp(edge a,edge b)
{
    return a.w<b.w;
}
int find(int x)
{
    int r=x;
    while(r!=pre[r])
        r=pre[r];
    int tmp;
    while(pre[x]!=r)
    {
        tmp=pre[x];
        pre[x]=r;
        x=tmp;
    }
    return r;
}
int merge(int u,int v)
{
    int f1=find(u);
    int f2=find(v);
    if(f1!=f2)
    {
        pre[f2]=f1;
        return 1;
    }
    return 0;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
            pre[i]=i;
        for(int i=0;i<m;i++)
            scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].w);
        sort(e,e+m,cmp);
        int maxx=0;
        for(int i=0;i<m;i++)
            if(merge(e[i].u,e[i].v))
                maxx=max(maxx,e[i].w);
        printf("%d\n",maxx);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值