http://acm.hdu.edu.cn/showproblem.php?pid=5938
Four Operations
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3285 Accepted Submission(s): 936
Problem Description
Little Ruins is a studious boy, recently he learned the four operations!
Now he want to use four operations to generate a number, he takes a string which only contains digits '1' - '9', and split it into 5 intervals and add the four operations '+', '-', '*' and '/' in order, then calculate the result(/ used as integer division).
Now please help him to get the largest result.
Input
First line contains an integer T, which indicates the number of test cases.
Every test contains one line with a string only contains digits '1'-'9'.
Limits
1≤T≤105
5≤length of string≤20
Output
For every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the result.
Sample Input
1 12345
Sample Output
Case #1: 1
Source
注意结果可能是负数
#include <bits/stdc++.h>
using namespace std;
#define ll long long
int main()
{
int t;
scanf("%d",&t );
for(int tt=1;tt<=t;tt++) {
char a[30];
scanf("%s",a);
ll ans=-10347812;
int len=strlen(a);
ll w=(ll)a[len-3]-'0';
ll x=(ll)a[len-2]-'0';
ll z=(ll)a[len-1]-'0';
z=w*x/z;
ll u,v;
u=0,v=0;
for(int i=0;i<len-4;i++)
{
u=u*10+a[i]-'0';
v=0;
for(int j=i+1;j<len-3;j++)
{
v=v*10+a[j]-'0';
}
ans=max(ans,u+v-z);
//printf("%lld+%lld-%lld=%lld\n",u,v,z,u+v-z );
}
x=(ll)a[len-4]-'0';
z=(ll)a[len-2]-'0';
z=z*10+(ll)a[len-1]-'0';
z=w*x/z;
u=0;
for(int i=0;i<len-5;i++)
{
u=u*10+a[i]-'0';
v=0;
for(int j=i+1;j<len-4;j++)
{
v=v*10+a[j]-'0';
}
//printf("%lld+%lld-%lld=%lld\n",u,v,z,u+v-z );
ans=max(ans,u+v-z);
}
printf("Case #%d: %lld\n",tt,ans);
}
return 0;
}