hdu Dollar Dayz 高精度完全背包

22 篇文章 0 订阅
21 篇文章 0 订阅

题目链接 

Dollar Dayz

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10456 Accepted: 3852

Description

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 
 

        1 @ US$3 + 1 @ US$2

        1 @ US$3 + 2 @ US$1

        1 @ US$2 + 3 @ US$1

        2 @ US$2 + 1 @ US$1

        5 @ US$1

Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5

 

这道题典型的完全背包,表示,你有N元钱,有k个菜 编号1——k,第i个菜的价钱为i元

那么

 

这道题,有点坑,我们拿个最大样例试一下就可以知道了,

 

这个怎么办呢,用两个long long 拼接一下

 

 
    for(int i = 1;i<=k;i++){
        for(int j = i ; j<=n ; j++){
    		a[j]=a[j]+a[j-i]+(dp[j]+dp[j-i])/mod;
        	dp[j] = dp[j] + dp[j-i];
        	dp[j]%=mod;
       	}
    }
 

 

​​​​#include<stdio.h>
#include<string.h>
using namespace std;
#define ll long long

 #define mod 1000000000000000000

int main(){
    int n,k;  
    scanf("%d%d",&n,&k);
    ll dp[1110];
    ll a[1110];
	ll b[1110];
	memset(a,0,sizeof(a));
	memset(dp,0,sizeof(dp));
    dp[0]=1;
    for(int i = 1;i<=k;i++){
        for(int j = i ; j<=n ; j++){
    		a[j]=a[j]+a[j-i]+(dp[j]+dp[j-i])/mod;
        	dp[j] = dp[j] + dp[j-i];
        	dp[j]%=mod;
       	}
    }
    if(a[n]==0){
        printf("%I64d\n",dp[n]);
    }else {
        printf("%I64d%018I64d\n",a[n],dp[n]);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值