There are NN children in kindergarten. Miss Li bought them NN candies. To make the process more interesting, Miss Li comes up with the rule: All the children line up according to their student number (1...N)(1...N), and each time a child is invited, Miss Li randomly gives him some candies (at least one). The process goes on until there is no candy. Miss Li wants to know how many possible different distribution results are there.
Input
The first line contains an integer TT, the number of test case.
The next TT lines, each contains an integer N.
1 \le T \le 1001≤T≤100
1 \le N \le 10^{100000}1≤N≤10100000
Output
For each test case output the number of possible results (mod 1000000007).
样例输入复制
-
1
-
4
样例输出复制
8
题目来源
欧拉公式 详细请看此博客 https://blog.csdn.net/henucm/article/details/82725457
#include<cstdio>
#include<cmath>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<map>
#include<vector>
#define N 1e5+10
#define ll long long
using namespace std;
const int mod=1e9+7;
char s[100010];
ll ol(ll x)
{
ll ans=x;
for(ll i=2;i*i<=x;i++)
{
if(!x%i)
{
ans=ans/i*(i-1);
while(x%i)
{
x=x/i;
}
}
}
if(x!=1)
{
ans=ans/x*(x-1);
}
return ans;
}
ll power(ll b)
{
ll ans=1;
ll a=2;
while(b)
{
if(b&1)
ans=ans*a%mod;
a=a*a%mod;
b>>=1;
}
return ans;
}
int main()
{
int t;
cin>>t;
while(t--)
{
cin>>s;
ll ans=0;
ll p=ol(mod);
int len=strlen(s);
for(ll i=0;i<len;i++)
ans=(ans*10+s[i]-'0')%p;
ans+=p;
printf("%lld\n",power(ans-1));
}
return 0;
}