hdu3555----Bomb 数位DP

HDU3555----Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 4594    Accepted Submission(s): 1601

Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
Output

For each test case, output an integer indicating the final points of the power.

Sample Input

3
1
50
500

Sample Output

0
1
15

传送门

题意:求1~N中含有数字49的个数     1 <= N <= 2^63-1
#include <cstdio>  
#include <cstring>  
  
using namespace std;  
  
int bit[25];  
__int64 dp[25][3];  
//dp[i][0]表示长度为i,没有49  
//dp[i][1]表示长度为i,没有49但前一位为4  
//dp[i][2]表示长度为i,包括49的个数  
  
/*limit表示是否有上限,比如n=1234,现在转移到12,如果下一位选3,那么再下一位就有上限, 
上限为4,如果不选3,那么下一位就没限制,最高位9,转移能保证转移到数比n小*/  
  
__int64 Dfs (int pos,int s,bool limit) //s为之前数字的状态  
{  
     if (pos==-1)  
        return s==2;  
     if (limit==false && ~dp[pos][s])  
        return dp[pos][s];  
     int i ,end=limit?bit[pos]:9;  
      __int64 ans=0;  
     for (i=0;i<=end;i++)  
     {  
        int nows=s;  
        if(s==0 && i==4)  
             nows=1;  
        if(s==1 && i!=9) //前一位为4  
             nows=0;  
        if(s==1 && i==4)  
             nows=1;  
        if(s==1 && i==9) //49  
             nows=2;  
         ans+=Dfs(pos-1 , nows , limit && i==end);  
     }  
    //limit==true则说明有限制,即所有可能并没有被全部记录,故此时记入dp数组  
    //limit==false则说明之后的分支状态已经搜索完全  
    return limit?ans:dp[pos][s]=ans;  
}  
  
int main ()  
{  
      __int64 n;  
     int T;  
     memset(dp,-1,sizeof(dp));  
     scanf("%d",&T);  
     while (T--)  
     {  
         scanf("%I64d",&n);  
         int len=0;  
         while (n)  
         {  
             bit[len++]=n%10;  
             n/=10;  
         }  
         printf("%I64d\n",Dfs(len-1,0,1));  
     }  
     return 0;  
}  

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值