PAT 1030. Travel Plan Dijkstra多边权

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40

Dijkstra多权问题,注意路径输出

直接上代码:

#include <bits/stdc++.h>

using namespace std;
const int maxn = 505;
const int INF = 0x3f3f3f3f;
int G[maxn][maxn],cost[maxn][maxn];
bool vis[maxn];
int d[maxn],c[maxn],pre[maxn];
int n,m,s,e;

void init(){
    for(int i=0;i<=500;i++)
        pre[i] = i;
}
void Dijkstra(){
    memset(d,INF,sizeof(d));
    memset(vis,false,sizeof(vis));
    memset(c,INF,sizeof(c));
    init();
    c[s] = 0;
    d[s] = 0;
    for(int i=0;i<n;i++){
        int MIN = INF,u = -1;
        for(int j=0;j<n;j++){
            if(vis[j]==false&&MIN>d[j]){
                u = j;
                MIN = d[j];
            }
        }
        if(u==-1) return;
        vis[u] = true;
        for(int v=0;v<n;v++){
            if(vis[v]==false&&G[u][v]!=INF){
                if(d[v]>d[u]+G[u][v]){
                    d[v] = d[u] + G[u][v];
                    pre[v] = u;
                    c[v] = c[u] + cost[u][v];
                }
                else if(d[v]==d[u]+G[u][v]){
                    if(c[v]>c[u]+cost[u][v]){
                        c[v] = c[u]+cost[u][v];
                        pre[v] = u;
                    }
                }
            }
        }
    }
}

void DFS(int vv){
    if(vv==s){
        cout<<vv<<" ";
        return;
    }
    DFS(pre[vv]);
    cout<<vv<<" ";
}


int main(int argc,char* argv[]){
    cin>>n>>m>>s>>e;
    memset(G,INF,sizeof(G));
    for(int i=0;i<m;i++){
        int u,v,l,cc;
        cin>>u>>v>>l>>cc;
        G[u][v] = G[v][u] = l;
        cost[u][v] = cost[v][u] = cc;
    }
    Dijkstra();
    DFS(e);
    cout<<d[e]<<" "<<c[e]<<endl;
    return 0;
}

代码二 (Dijkstra+DFS)

#include <bits/stdc++.h>

using namespace std;
const int maxn = 505;
const int INF = 0x3f3f3f3f;
int G[maxn][maxn],cost[maxn][maxn];
bool vis[maxn];
int d[maxn],c[maxn];
vector<int>pre[maxn];
vector<int>tempath,path;
int n,m,s,e;
void Dijkstra(){
    memset(vis,false,sizeof(vis));
    memset(d,INF,sizeof(d));
    d[s] = 0;
    for(int i=0;i<n;i++){
        int MIN = INF, u = -1;
        for(int j=0;j<n;j++){
            if(vis[j]==false&&d[j]<MIN){
                MIN = d[j];
                u = j;
            }
        }
        if(u==-1) return;
        vis[u] = true;
        for(int v=0;v<n;v++){
            if(vis[v]==false&&G[u][v]!=INF){
                if(d[v]>d[u]+G[u][v]){
                    d[v] = d[u] + G[u][v];
                    pre[v].clear();
                    pre[v].push_back(u);
                }
                else if(d[v]==d[u]+G[u][v]){
                    pre[v].push_back(u);
                }
            }
        }
    }
}
int optvlaue = INF;

void DFS(int v){
    if(v==s){
        tempath.push_back(v);
        int vlaue = 0;
        for(int i=tempath.size()-1;i>0;i--){
            int id = tempath[i],idNext = tempath[i-1];
            vlaue += cost[id][idNext];
        }
        if(vlaue<optvlaue){
            optvlaue = vlaue;
            path = tempath;
        }
        tempath.pop_back();
        return;
    }
    tempath.push_back(v);
    for(int i=0;i<pre[v].size();i++){
        DFS(pre[v][i]);
    }
    tempath.pop_back();
}
int main(int argc,char* argv[]){
    cin>>n>>m>>s>>e;
    memset(G,INF,sizeof(G));
    memset(cost,INF,sizeof(cost));
   // optvlaue = INF;
    for(int i=0;i<m;i++){
        int u,v,l,cc;
        cin>>u>>v>>l>>cc;
        G[u][v] = G[v][u] = l;
        cost[v][u] = cost[u][v] = cc;
    }
    Dijkstra();
    DFS(e);
    for(int i=path.size()-1;i>=0;i--){
        cout<<path[i]<<" ";
    }
    cout<<d[e]<<" "<<optvlaue<<endl;
    return 0;
}


Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值