pat basic 1095 解码PAT准考证

PAT 准考证号由 4 部分组成:

  • 第 1 位是级别,即 T 代表顶级;A 代表甲级;B 代表乙级;
  • 第 2~4 位是考场编号,范围从 101 到 999;
  • 第 5~10 位是考试日期,格式为年、月、日顺次各占 2 位;
  • 最后 11~13 位是考生编号,范围从 000 到 999。

现给定一系列考生的准考证号和他们的成绩,请你按照要求输出各种统计信息。

输入格式:

输入首先在一行中给出两个正整数 N(≤104)和 M(≤100),分别为考生人数和统计要求的个数。

接下来 N 行,每行给出一个考生的准考证号和其分数(在区间 [0,100] 内的整数),其间以空格分隔。

考生信息之后,再给出 M 行,每行给出一个统计要求,格式为:类型 指令,其中

  • 类型 为 1 表示要求按分数非升序输出某个指定级别的考生的成绩,对应的 指令 则给出代表指定级别的字母;
  • 类型 为 2 表示要求将某指定考场的考生人数和总分统计输出,对应的 指令 则给出指定考场的编号;
  • 类型 为 3 表示要求将某指定日期的考生人数分考场统计输出,对应的 指令 则给出指定日期,格式与准考证上日期相同。

输出格式:

对每项统计要求,首先在一行中输出 Case #: 要求,其中 # 是该项要求的编号,从 1 开始;要求 即复制输入给出的要求。随后输出相应的统计结果:

  • 类型 为 1 的指令,输出格式与输入的考生信息格式相同,即 准考证号 成绩。对于分数并列的考生,按其准考证号的字典序递增输出(题目保证无重复准考证号);
  • 类型 为 2 的指令,按 人数 总分 的格式输出;
  • 类型 为 3 的指令,输出按人数非递增顺序,格式为 考场编号 总人数。若人数并列则按考场编号递增顺序输出。

如果查询结果为空,则输出 NA

输入样例:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

输出样例:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

解题思路:

非常复杂的一道题啊,要先把数据读进来,再提取出各种信息。然后再根据要求分情况处理。我的做法是针对类型一的要求排序,其他两种情况不用排序也可以,把程序总体控制在O(N^2)以内应该就能顺利通过了。注意每种情况没有查询到结果的时候要输出NA,输出编号类的数据时要保留字符宽度。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define MAXN 14
#define MAXROOMS 1000

typedef struct _node *PtrN;
typedef struct _node {
	char str[MAXN];
	char lv;
	int exam_no, exam_date, can_id, score;
} Candidate;

typedef struct _node2 *PtrP;
typedef struct _node2 {
	int exam_no, candidates;
} Pair;

int compare1(const void *a, const void *b) {
	PtrN pa = (PtrN)a, pb = (PtrN)b;
	if ( pa->lv != pb->lv )
		return (int)(pa->lv - pb->lv);
	else if ( pa->score != pb->score )
		return pb->score - pa->score;
	else
		return strcmp(pa->str, pb->str);
}

int compare2(const void *a, const void *b) {
	PtrP pa = (PtrP)a, pb = (PtrP)b;
	return pb->candidates - pa->candidates;
}

int main(int argc, const char *argv[]) {
	int N, M, i, j, type;
	char temp[MAXN], strcode[MAXN];
	if ( scanf("%d %d", &N, &M)==EOF ) printf("error\n");
	Candidate students[N];

	for ( i=0; i<N; ++i ) {
		if ( scanf("%s %d", students[i].str, &students[i].score)==EOF ) printf("error\n");
		students[i].lv = students[i].str[0];
		memcpy(temp, &students[i].str[1], 3);
		temp[3] = '\0';
		students[i].exam_no = atoi(temp);
		memcpy(temp, &students[i].str[10], 3);
		temp[3] = '\0';
		students[i].can_id = atoi(temp);
		memcpy(temp, &students[i].str[4], 6);
		temp[6] = '\0';
		students[i].exam_date = atoi(temp);
	}
	qsort(students, N, sizeof(Candidate), compare1);

	for ( i=1; i<=M; ++i ) {
		if ( scanf("%d %s", &type, strcode)==EOF ) printf("error\n");
		printf("Case %d: %d %s\n", i, type, strcode);
		int flag = 1, count = 0, sum = 0, code = atoi(strcode);
		char level = strcode[0];
		Pair stu_in_room[MAXROOMS] = {{0,0},};
		switch ( type ) {
			case 1:
				for ( j=0; j<N; ++j ) {
					if ( students[j].lv == level ) {
						printf("%s %d\n", students[j].str, students[j].score);
						flag = 0;
					}
				}
				if ( flag ) printf("NA\n");
				break;
			case 2:
				for ( j=0; j<N; ++j ) {
					if ( students[j].exam_no == code ) {
						sum += students[j].score;
						++count;
						flag = 0;
					}
				}
				if ( flag )
					printf("NA\n");
				else
					printf("%d %d\n", count, sum);
				break;
			case 3:
				for ( j=0; j<N; ++j ) {
					if ( students[j].exam_date == code ) {
						stu_in_room[students[j].exam_no].exam_no = students[j].exam_no;
						++stu_in_room[students[j].exam_no].candidates;
						flag = 0;
					}
				}
				if ( flag ) {
					printf("NA\n");
				} else {
					qsort(stu_in_room, MAXROOMS, sizeof(Pair), compare2);
					for ( j=0; j<MAXROOMS; ++j ) {
						if ( stu_in_room[j].candidates == 0 ) break;
						printf("%03d %d\n", stu_in_room[j].exam_no, stu_in_room[j].candidates);
					}
				}
				break;
			default:
				printf("NA\n");
		}
	}

	return EXIT_SUCCESS;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值