poj 2231Moo Volume

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20699 Accepted: 6249

Description

Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise. 

FJ's N cows (1 <= N <= 10,000) all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.

Input

* Line 1: N 

* Lines 2..N+1: The location of each cow (in the range 0..1,000,000,000).

Output

There are five cows at locations 1, 5, 3, 2, and 4.

Sample Input

5
1
5
3
2
4

Sample Output

40

Hint

INPUT DETAILS: 

There are five cows at locations 1, 5, 3, 2, and 4. 

OUTPUT DETAILS: 

Cow at 1 contributes 1+2+3+4=10, cow at 5 contributes 4+3+2+1=10, cow at 3 contributes 2+1+1+2=6, cow at 2 contributes 1+1+2+3=7, and cow at 4 contributes 3+2+1+1=7. The total volume is (10+10+6+7+7) = 40.


解题思路:本题要求的就是任意两数之差的和。。。如果直接两层循环肯定会超时,这里可以利用动态规划的思想求解。
首先我们将这些数按从小到大排序,我们假定dp[i]为第i个数与前i-1个数差和,那么我们可以推导出递推公式:
dp[i] = dp[i-1]+(i-1)*(a[i] - a[i-1])。。最后将dp[i]都累加起来,记得还要乘以2,因为是双向的,dp[i]只是单向。。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn = 10010;
int n;
__int64 dp[maxn],a[maxn];

int cmp(__int64 a,__int64 b)
{
	return a < b;
}

int main()
{	
	while(scanf("%d",&n)!=EOF)
	{
		for(int i = 1; i <= n; i++)
			scanf("%I64d",&a[i]);
		sort(a+1,a+n+1,cmp);
		for(int i = 1; i <= n; i++)
		{
			dp[i] = dp[i-1]+(i-1)*(a[i]-a[i-1]);
		}
		__int64 sum = 0;
		for(int i = 1; i <= n; i++)
			sum += dp[i];
		printf("%I64d\n",sum<<1);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值