hdu 2428(哈希)

Stars

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)


Problem Description
    Lucy loves stars very much. There are N (1 <= N <= 1000) stars in the sky. Assume the sky is a flat plane. All of the stars lie on it with a location (x, y), -10000 <= x, y <= 10000. Now, Lucy wants you to tell her how many squares with each of four vertices formed by these stars, and the edges of the squares should parallel to the coordinate axes.
 

Input
    The first line of input is the number of test case.
    The first line of each test case contains an integer N. The following N lines each contains two integers x, y, meaning the coordinates of the stars. All the coordinates are different.

 

Output
    For each test case, output the number of squares in a single line.
 

Sample Input
  
  
2 1 1 2 4 0 0 1 0 1 1 0 1
 

Sample Output
  
  
0 1
解题思路:这道题目就是找到两点,然后查看另外两点是否存在。。。。典型的哈希
AC:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int maxn = 1010;
struct node
{
	int x,y;
}star[maxn];
struct link
{
	int id;
	int next;
}Hash[maxn];
int n,h[maxn*3],cnt;

int calc(int x,int y)
{
	int key = x*x + y*y;
	return key % 1003;
}

void add(int id)
{
	int key = calc(star[id].x,star[id].y);
	Hash[cnt].id = id;
	Hash[cnt].next = h[key];
	h[key] = cnt++;
}

bool find(int x, int y)
{
	int key = calc(x,y);
	int p = h[key];
	while(p != -1)
	{
		int t = Hash[p].id;
		if(star[t].x == x && star[t].y == y)
			return true;
		p = Hash[p].next;
	}
	return false;
}

int main()
{	
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		memset(h,-1,sizeof(h));
		memset(Hash,-1,sizeof(Hash));
		for(int i = 1; i <= n; i++)
		{
			scanf("%d%d",&star[i].x,&star[i].y);
			add(i);
		}
		int ans = 0;
		for(int i = 1; i <= n; i++)
			for(int j = i+1; j <= n; j++)
			{
				if(star[i].x == star[j].x)	//横坐标相等,往左右两面找正方形
				{
					int dy = abs(star[i].y - star[j].y);
					if(find(star[i].x + dy, star[i].y) && find(star[j].x + dy, star[j].y))
						ans++;
					if(find(star[i].x - dy, star[i].y) && find(star[j].x - dy, star[j].y))
						ans++;
				}
				else if(star[i].y == star[j].y) //纵坐标相等,往上下找正方形
				{
					int dx = abs(star[i].x - star[j].x);
					if(find(star[i].x, star[i].y + dx) && find(star[j].x, star[j].y + dx))
						ans++;
					if(find(star[i].x, star[i].y - dx) && find(star[j].x, star[j].y - dx))
						ans++;
				}
			}
			printf("%d\n",ans>>2);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值