hdu2428 Stars

Stars

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1764    Accepted Submission(s): 612


Problem Description
    Lucy loves stars very much. There are N (1 <= N <= 1000) stars in the sky. Assume the sky is a flat plane. All of the stars lie on it with a location (x, y), -10000 <= x, y <= 10000. Now, Lucy wants you to tell her how many squares with each of four vertices formed by these stars, and the edges of the squares should parallel to the coordinate axes.
 

Input
    The first line of input is the number of test case.
    The first line of each test case contains an integer N. The following N lines each contains two integers x, y, meaning the coordinates of the stars. All the coordinates are different.

 

Output
    For each test case, output the number of squares in a single line.
 

Sample Input
  
  
2 1 1 2 4 0 0 1 0 1 1 0 1
 

Sample Output
  
  
0 1
 

全哈希。

#include<cstdio>
#include<cstring>
#include<string.h>

using namespace std;
const int maxn=1005;
const int hashsize=2006;
struct Point
{
	int x;
	int y;
	Point(int a=0,int b=0)
	{
		x=a;
		y=b;
	}
}stars[maxn];

int head[hashsize];
int pre[maxn];

int hash(Point p)
{
	int c=hashsize;
	return ((p.x*20005+p.y)%c+c)%c;
}

int find(int x,int y)
{
	int f=hash(Point(x,y));
	for(int i=head[f];i>=0;i=pre[i])
	{
		if(stars[i].x==x&&stars[i].y==y)
		return 1;
	}
	return 0;
}

int main()
{
	int casen;
	scanf("%d",&casen);
	while(casen--)
	{
		int n;
		scanf("%d",&n);
		memset(head,-1,sizeof(head));
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&stars[i].x,&stars[i].y);
			int f=hash(stars[i]);
			pre[i]=head[f];
			head[f]=i;
		}
		int sum=0;
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<n;j++)
			{
				if(stars[i].x>=stars[j].x)
				continue;
				if(stars[i].x-stars[j].x!=stars[i].y-stars[j].y)
				continue;
				if(!find(stars[i].x,stars[j].y))continue;
				if(!find(stars[j].x,stars[i].y))continue;
				sum++;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值