【HDU - 3501】 Calculation 2 【欧拉求和公式】

Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
Output
For each test case, you should print the sum module 1000000007 in a line.
Sample Input
3
4
0
Sample Output
0
2

这里写图片描述

代码

#include<cstdio>
using namespace std ;
typedef long long LL ;

const int MAXN = 3000000 +10;
const int MAXM = 216816+10 ;
const LL mod  = 1000000007 ;

LL eular(LL n){
    LL ans=n;
    for(LL i=2;i*i<=n;i++){
        if(n%i==0) {
            ans=ans/i*(i-1);
            while(n%i==0) n/=i;
        }
    }
    if(n>1) ans=ans/n*(n-1);
    return ans;
}
int main(){ 
    LL n;
    while(scanf("%lld",&n)&&n){
        LL ans=(((n-1)*n/2)%mod-(n*eular(n)/2)%mod+mod)%mod;//这里手贱,一直提前取模,结果一直wa,
 //因为是两者是减的关系,有可能是负数,我们要先加mod然后最后再取mod。 
 //LL ans=((n-1)*n/2-n*eular(n)/2)%mod;或者这样写    
        printf("%lld\n",ans);
     }

    return  0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值