hdu 3873(限制最短路---待解决)

Invade the Mars

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 365768/165536 K (Java/Others)


Problem Description
It's now the year 21XX,when the earth will explode soon.The evil U.S. decided to invade the Mars to save their lives.
But the childlike Marsmen never keeps any army,because war never take place on the Mars.So it's very convenient for the U.S. to act the action.
Luckily,the Marsmen find out the evil plan before the invadation,so they formed a defense system.The system provides enchantment for some citys,and the enchantment generator for city A maybe set in city B,and to make things worse,both city B and C and more will provide echantment for city A.
The satelite of U.S. has got the map of the Mars.And they knows that when they enter a city,they can destory all echantment generator in this city at once,and they can enter a city only if they has destoryed all enchantment generator for this city,but troops can stay at the outside of the city and can enter it at the moment its echantment is destoryed.Of course the U.S. army will face no resistance because the Mars keep no army,so troops can invade in many way at the same time.
Now the U.S. will invade the Mars,give you the map,your task is to calculate the minimium time to enter the capital of the Mars.
 

Input
The first line contains an integer T,which is the number of test cases.
For each testcase:
The first line contains two integers N and M,1<=N<=3000,1<=M<=70000,the cities is numbered from 1 to N and the U.S. landed on city 1 while the capital of the Mars is city N.
The next M lines describes M paths on the Mars.Each line contains three integers ai,bi and wi,indicates there is a unidirectional path form ai to bi lasts wi minutes(1<=wi<=10^8).
The next N lines describes N citys,the 1+M+i line starts with a integer li,followed with li integers, which is the number of cities has a echantment generator protects city i.
It's guaranteed that the city N will be always reachable.
 

Output
For each case,print a line with a number indicating the minimium time needed to enter the capital of the Mars.
 

Sample Input
  
  
1 6 6 1 2 1 1 4 3 2 3 1 2 5 2 4 6 2 5 3 2 0 0 0 1 3 0 2 3 5
 

Sample Output
  
  
5
Hint
The Map is like this: We can follow these ways to achieve the fastest speed: 1->2->3,1->2->5,1->4->6.
 

这道题是有限制的最短路,和以前做的不同,这里是点的限制。这题的做法很特别,需要理解好迪杰斯特拉算法的精髓,这道题由于有节点的限制,所以当某一节点的限制节点全部更新完,即in[u] == 0,才能将其放入优先队列。dis[i]表示破坏i点所需的最小时间,pro[i]表示解除i点控制所需的最小时间,那么破坏i所需的最小时间dis[i] = max(dis[i],pro[i])
一直在WA。。。不知道哪里出了问题。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;

typedef pair<long long,int> Pair;
const int maxn = 3005;
const long long inf = 1<<55;
struct Node
{
	int u,w;

	Node(int _u,int _w)
	{
		u = _u;
		w = _w;
	}
};
int n,m,in[maxn];
long long dis[maxn],pro[maxn];
bool vis[maxn];
vector<Node> g[maxn];
vector<int> conq[maxn];

void spfa()
{
	for(int i = 1; i <= n; i++)
	{
		dis[i] = inf;
		pro[i] = 0;
	}
	memset(vis,false,sizeof(vis));
	priority_queue<Pair,vector<Pair>,greater<Pair>> q;
	dis[1] = 0;
	q.push(make_pair(dis[1],1));
	while(!q.empty())
	{
		Pair p = q.top();
		q.pop();
		int u = p.second;
		if(vis[u] == true) continue;
		vis[u] = true;
		for(int i = 0; i < conq[u].size(); i++)
		{
			int v = conq[u][i];
			in[v]--;
			pro[v] = max(pro[v],dis[u]);
			if(dis[v] != inf && in[v] == 0)
			{
				dis[v] = max(dis[v],pro[v]);
				q.push(make_pair(dis[v],v));
			}
		}
		for(int i = 0; i < g[u].size(); i++)
		{
			int v = g[u][i].u;
			if(dis[v] > dis[u] + g[u][i].w)
			{
				dis[v] = max(dis[u] + g[u][i].w,pro[v]);
				if(dis[v] != inf && in[v] == 0)
					q.push(make_pair(dis[v],v));
			}
		}
	}
}

int main()
{
	int t,u,v,w;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(int i = 1; i <= n; i++)
		{
			g[i].clear();
			conq[i].clear();
		}
		for(int i = 1; i <= m; i++)
		{
			scanf("%d%d%d",&u,&v,&w);
			g[u].push_back(Node(v,w));
			g[v].push_back(Node(u,w));
		}
		for(int i = 1; i <= n; i++)
		{
			scanf("%d",&in[i]);
			for(int j = 1; j <= in[i]; j++)
			{
				scanf("%d",&u);
				conq[u].push_back(i);
			}
		}
		spfa();
		printf("%I64d\n",dis[n]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值