hdu 3790(最短路)

最短路径问题

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
给你n个点,m条无向边,每条边都有长度d和花费p,给你起点s终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。
 

Input
输入n,m,点的编号是1~n,然后是m行,每行4个数 a,b,d,p,表示a和b之间有一条边,且其长度为d,花费为p。最后一行是两个数 s,t;起点s,终点。n和m为0时输入结束。
(1<n<=1000, 0<m<100000, s != t)
 

Output
输出 一行有两个数, 最短距离及其花费。
 

Sample Input
  
  
3 2 1 2 5 6 2 3 4 5 1 3 0 0
 

Sample Output
  
  
9 11
 

解题思路:最短路水题,只需要在松弛操作部分改动一点点即可。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int maxn = 1005;
const int inf = 0x3f3f3f3f;
int n,m,cnt,map[maxn][maxn],cost[maxn][maxn];
int dis[maxn],price[maxn];
bool vis[maxn];

void Dijkstra(int s,int t)
{
	int k = s,MIN;
	memset(vis,false,sizeof(vis));
	memset(dis,inf,sizeof(dis));
	memset(price,inf,sizeof(price));
	for(int i = 1; i <= n; i++)
		if(i != s)
		{
			dis[i] = map[s][i];
			price[i] = cost[s][i];
		}
	vis[k] = true;
	for(int i = 1; i < n; i++)
	{
		MIN = inf;
		for(int j = 1; j <= n; j++)
		{
			if(vis[j] == true) continue;
			if(MIN > dis[j])
			{
				MIN = dis[j];
				k = j;
			}
		}
		vis[k] = true;
		for(int j = 1; j <= n; j++)
		{
			if(vis[j] == true) continue;
			if(dis[j] > dis[k] + map[k][j])
			{
				dis[j] = dis[k] + map[k][j];
				price[j] = price[k] + cost[k][j];
			}
			else if(dis[j] == dis[k] + map[k][j] && price[j] > price[k] + cost[k][j])
				price[j] = price[k] + cost[k][j];
		}
	}
	printf("%d %d\n",dis[t],price[t]);
}

int main()
{
	int u,v,len,c,s,t;
	while(scanf("%d%d",&n,&m),n+m)
	{
		memset(map,inf,sizeof(map));
		memset(cost,inf,sizeof(cost));
		for(int i = 1; i <= m; i++)
		{
			scanf("%d%d%d%d",&u,&v,&len,&c);
			if(map[u][v] > len)
			{
				map[u][v] = map[v][u] = len;
				cost[u][v] = cost[v][u] = c;
			}
			else if(map[u][v] == len && cost[u][v] > c)
				cost[u][v] = cost[v][u] = c;
		}
		scanf("%d%d",&s,&t);
		Dijkstra(s,t);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值