poj 3013(最短路变形)

Big Christmas Tree
Time Limit: 3000MS Memory Limit: 131072K
Total Submissions: 22662 Accepted: 4920

Description

Christmas is coming to KCM city. Suby the loyal civilian in KCM city is preparing a big neat Christmas tree. The simple structure of the tree is shown in right picture.

The tree can be represented as a collection of numbered nodes and some edges. The nodes are numbered 1 through n. The root is always numbered 1. Every node in the tree has its weight. The weights can be different from each other. Also the shape of every available edge between two nodes is different, so the unit price of each edge is different. Because of a technical difficulty, price of an edge will be (sum of weights of all descendant nodes) × (unit price of the edge).

Suby wants to minimize the cost of whole tree among all possible choices. Also he wants to use all nodes because he wants a large tree. So he decided to ask you for helping solve this task by find the minimum cost.

Input

The input consists of T test cases. The number of test cases T is given in the first line of the input file. Each test case consists of several lines. Two numbers ve (0 ≤ ve ≤ 50000) are given in the first line of each test case. On the next line, v positive integers wi indicating the weights of v nodes are given in one line. On the following e lines, each line contain three positive integers abc indicating the edge which is able to connect two nodes a and b, and unit price c.

All numbers in input are less than 216.

Output

For each test case, output an integer indicating the minimum possible cost for the tree in one line. If there is no way to build a Christmas tree, print “No Answer” in one line.

Sample Input

2
2 1
1 1
1 2 15
7 7
200 10 20 30 40 50 60
1 2 1
2 3 3
2 4 2
3 5 4
3 7 2
3 6 3
1 5 9

Sample Output

15

1210

这个要有个重要的转化;首先price of an edge will be (sum of weights of all descendant nodes) × (unit price of the edge).

    这句指出每条边的代价为该边所有子孙节点权值之和乘以该边的权值。

    换个角度就是每个节点的代价为该节点到根节点的所有边的权值乘以该节点的权值。

   其实就是求从端点1到每个点的最短路径*改点的权值,,然后之和;

#include <queue>
#include <stdio.h>
#include <iostream>
using namespace std;
const long long INF=10000000000;
const int M=50005;
int n,m,edgeNum;
long long dis[M];
int head[M];
int visit[M];
int weight[M];
struct Edge{
    int w;
    int to;
    int next;
}edge[M*2];
struct Node{
    int u;
    int dis;
    bool operator < (const Node &a) const{
        return dis>a.dis;
    }
};

void init(){
    int i;
    edgeNum=0;
    for(i=0;i<M;i++){
        visit[i]=0;
        head[i]=-1;
        dis[i]=INF;
    }
}

void addEdge(int a,int b,int c)
{
    edge[edgeNum].w = c;
    edge[edgeNum].to = b;
    edge[edgeNum].next = head[a];
    head[a] = edgeNum++;
}

void Dij(int u)
{
    int i,v;
    Node temp,now;
    priority_queue<Node> q;
    temp.dis = 0;
    temp.u = u;
    dis[u] = 0;
    q.push(temp);
    while(!q.empty())
	{
        temp=q.top();
        q.pop();
        visit[temp.u]=1;
        for(i = head[temp.u]; i != -1; i = edge[i].next)
		{
            v=edge[i].to;
            if(!visit[v]&&dis[v]>dis[temp.u]+edge[i].w)
			{
                dis[v]=dis[temp.u]+edge[i].w;
                now.dis=dis[v];
                now.u=v;
                q.push(now);
            }
        }
    }
    return ;
}
int main()
{
    int T,a,b,c,i;
    scanf("%d",&T);
    while(T--)
	{
        scanf("%d%d",&n,&m);
        init();
        for(i = 1; i <= n; i++)
            scanf("%d",&weight[i]);
        for(i = 0; i < m; i++)
		{
            scanf("%d%d%d",&a,&b,&c);
            addEdge(a,b,c);
            addEdge(b,a,c);
        }
        Dij(1);
        long long res=0;
        for(i = 1; i <= n; i++){
            if(dis[i]==INF) break;
            res+=dis[i]*weight[i];
        }
        if(i > n) printf("%lld\n",res);
        else puts("No Answer");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值