hdu 4886(hash + dfs)

TIANKENG’s restaurant(Ⅱ)

Time Limit: 16000/8000 MS (Java/Others)    Memory Limit: 130107/65536 K (Java/Others)


Problem Description
After improving the marketing strategy, TIANKENG has made a fortune and he is going to step into the status of TuHao. Nevertheless, TIANKENG wants his restaurant to go international, so he decides to name his restaurant in English. For the lack of English skills, TIANKENG turns to CC, an English expert, to help him think of a property name. CC is a algorithm lover other than English, so he gives a long string S to TIANKENG. The string S only contains eight kinds of letters-------‘A’, ‘B’, ‘C’, ‘D’, ‘E’, ‘F’, ‘G’, ‘H’. TIANKENG wants his restaurant’s name to be out of ordinary, so the restaurant’s name is a string T which should satisfy the following conditions: The string T should be as short as possible, if there are more than one strings which have the same shortest length, you should choose the string which has the minimum lexicographic order. Could you help TIANKENG get the name as soon as possible?

Meanwhile, T is different from all the substrings of S. Could you help TIANKENG get the name as soon as possible?
 

Input
The first line input file contains an integer T(T<=50) indicating the number of case.
In each test case:
Input a string S. the length of S is not large than 1000000.
 

Output
For each test case:
Output the string t satisfying the condition.(T also only contains eight kinds of letters-------‘A’, ‘B’, ‘C’, ‘D’, ‘E’, ‘F’, ‘G’, ‘H’.)
 

Sample Input
  
  
3 ABCDEFGH AAABAACADAEAFAGAH ACAC
 

Sample Output
  
  
AA BB B

题意:

1、找一个字符串s使得 s不是给定母串的子串

2、且s要最短

3、s在最短情况下字典序最小

解题思路:首先要肯定的一点就是,这个串s是不会超过8位的。8位串的话用dfs搜索肯定是没问题的,关键是如何判断字符串是否是子串,这里可以用哈希来解决。不过这里的哈希确实用的比较巧妙,我没有想到,h[i][ans]表示长度为i,哈希值为ans的串是否存在。这样直接传s的哈希值即可。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int maxn = 1000005;
int flag,h[8][2496764];
char str[maxn],res[8];

bool dfs(int top,int hash,int dep)
{
	if(top == dep)
	{
		for(int i = 0; i < 8; i++)
		{
			if(h[top][hash * 8 + i] != flag)
			{
				res[top] = i + 'A';
				res[top + 1] = 0;
				return true;
			}
		}
		return false;
	}
	for(int i = 0; i < 8; i++)
	{
		res[top] = i + 'A';
		if(dfs(top+1,hash * 8 + i, dep)) return true;
	}
	return false;
}

int main()
{
	int t;
	scanf("%d",&t);
	flag = 0;
	while(t--)
	{
		flag++;
		scanf("%s",str);
		for(int i = 0; str[i]; i++)
		{
			int ans = 0;
			for(int j = 0; j < 7 && str[i+j]; j++)
			{
				ans = ans * 8 + str[i + j] - 'A';  
				h[j][ans] = flag;
			}
		}
		for(int i = 0; i < 8; i++)
			if(dfs(0,0,i)) break;
		puts(res);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值