hdu 5212(莫比乌斯反演)

Code

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)


Problem Description
WLD likes playing with codes.One day he is writing a function.Howerver,his computer breaks down because the function is too powerful.He is very sad.Can you help him?

The function:


int calc
{
  
  int res=0;
  
  for(int i=1;i<=n;i++)
    
    for(int j=1;j<=n;j++)
    
    {
      
      res+=gcd(a[i],a[j])*(gcd(a[i],a[j])-1);
      
      res%=10007;
    
    }
  
  return res;

}
 

Input
There are Multiple Cases.(At MOST 10 )

For each case:

The first line contains an integer N(1N10000) .

The next line contains N integers a1,a2,...,aN(1ai10000) .
 

Output
For each case:

Print an integer,denoting what the function returns.
 

Sample Input
  
  
5 1 3 4 2 4
 

Sample Output
  
  
64
Hint
gcd(x,y) means the greatest common divisor of x and y.

解题思路:这道题关键是找到相同的gcd(x,y)的对数。可以用莫比乌斯反演。

参考博客:http://blog.csdn.net/Yukizzz/article/details/51541973

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

typedef long long LL;
const int maxn = 10005;
const int mod = 10007;
bool check[maxn];
int mu[maxn],prime[maxn];
int n,m,a[maxn],cnt[maxn];
LL F[maxn];

void moblus()
{
	int tot = 0;
	memset(check,false,sizeof(check));
	mu[1] = 1;
	for(int i = 2; i <= maxn; i++)
	{
		if(!check[i])
		{
			prime[tot++] = i;
			mu[i] = -1;
		}
		for(int j = 0; j < tot; j++)
		{
			if(i * prime[j] > maxn) break;
			check[i * prime[j]] = true;
			if(i % prime[j] == 0)
			{
				mu[i * prime[j]] = 0;
				break;
			}
			else mu[i * prime[j]] = -mu[i];
		}
	}
}

int main()
{
	moblus();
	while(scanf("%d",&n)!=EOF)
	{
		memset(cnt,0,sizeof(cnt));
		m = 0;
		for(int i = 1; i <= n; i++)
		{
			scanf("%d",&a[i]);
			cnt[a[i]]++;
			m = max(m,a[i]);
		}
		for(int i = 1; i <= m; i++)
		{
			F[i] = 0;
			for(int j = i; j <= m; j += i)
				F[i] += cnt[j];
			F[i] = F[i] * F[i];
		}
		LL tmp,ans = 0;
		for(int i = 1; i <= m; i++) //枚举最大公约数
		{
			tmp = 0;
			for(int j = i; j <= m; j += i)
				tmp = (tmp + mu[j / i] * F[j] % mod) % mod;
			ans = (ans + tmp * i % mod * (i - 1) % mod) % mod;
		}
		printf("%lld\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值