1139. First Contact (30)

  1. First Contact (30)

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B – quite a long shot, isn’t it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N <= 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:
10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003
Sample Output:
4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

这题目很坑,当时没做出来,we use a negative sign to represent girls.这句话看错了。应该是负号代表女生,而不是负数代表女生。

下面给出一个暴力循环的算法。

#include<iostream>
#include<vector>
#include<cstdio>
#include<algorithm>
using namespace std;
int per[10000];//性别标记
int vis[10000];//访问标记
vector<int> v[10000];
struct node{
int a,b;};
struct node ans[100000];//存储最后结果
int index1=0;
int aa,bb;
int getnum(char num[])//获得数字编号
{
    int sum=0;
    if (num[0]=='-')
    {
        for (int i=1;i<=4;i++)
            sum=sum*10+num[i]-'0';
    }
    else
    {
        for (int i=0;i<4;i++)
            sum=sum*10+num[i]-'0';
    }
    return sum;
}
int getsign(char num[])//或得性别
{
    if (num[0]=='-')
        return 0;
    return 1;
}
bool cmp(struct node p1,struct node p2)
{
    if (p1.a==p2.a)
        return p1.b<p2.b;
    return p1.a<p2.a;
}
void fun(int s,int t)
{
    for (int i=0;i<v[s].size();i++)
    {
        int t1=v[s][i];
        if (vis[t1]==0&&per[t1]==per[s])//A的朋友要和A一样的性别
        {
            vis[t1]=1;
            for (int j=0;j<v[t1].size();j++)
            {
                int t2=v[t1][j];

                if (vis[t2]==0&&per[t2]==per[t])//B的朋友要和B一样的性别
                {
                    vis[t2]=1;
                    for (int k=0;k<v[t2].size();k++)
                    {
                        if (v[t2][k]==t)
                        {
                            ans[index1].a=t1;
                            ans[index1++].b=t2;
                        }
                    }
                    vis[t2]=0;
                }
            }
            vis[t1]=0;
        }
    }
}
int main()
{
    int n,m;
    char ta[10],tb[10];
    scanf("%d %d",&n,&m);
    for (int i=0;i<m;i++)
    {
        scanf("%s %s",&ta,&tb);
        aa=getnum(ta);
        bb=getnum(tb);
        if (getsign(ta))
            per[aa]=1;
        else
            per[aa]=0;
        if (getsign(tb))
            per[bb]=1;
        else
            per[bb]=0;
        v[aa].push_back(bb);
        v[bb].push_back(aa);
    }
    int k;
    scanf("%d",&k);
    for (int i=0;i<k;i++)
    {
        scanf("%d %d",&aa,&bb);
        if (aa<0) aa=-aa;
        if (bb<0) bb=-bb;
        index1=0;
        vis[aa]=1;
        vis[bb]=1;
        fun(aa,bb);
        vis[aa]=0;
        vis[bb]=0;
        sort(ans,ans+index1,cmp);
        int total=0;
        printf("%d\n",index1);
         for (int j=0;j<index1;j++)
        {
            printf("%04d %04d\n",ans[j].a,ans[j].b);
        }
    }
    return  0;
}

还有一个广搜算法,由于本人太菜不会剪枝,所以最后一个数据,超时。使用的数据结构和上面差不多(就不多加注释了),如果各位有好的见解,欢迎评论

#include<iostream>
#include<vector>
#include<cstdio>
#include<algorithm>
using namespace std;
int per[10000];
int vis[10000];
vector<int> v[10000],pa;
struct node{
int a,b;};
struct node ans[10000];
int index=0;
int a,b;
bool cmp(struct node p1,struct node p2)
{
    if (p1.a==p2.a)
        return p1.b<p2.b;
    return p1.a<p2.a;
}
int getnum(char num[])
{
    int sum=0;
    if (num[0]=='-')
    {
        for (int i=1;i<=4;i++)
            sum=sum*10+num[i]-'0';
    }
    else
    {
        for (int i=0;i<4;i++)
            sum=sum*10+num[i]-'0';
    }
    return sum;
}
int getsign(char num[])
{
    if (num[0]=='-')
        return 0;
    return 1;
}
void fun(int s,int t,int path)
{

    if (path>=4)
    {
        if (path==4&&pa[2]==t)
        {
            if (per[a]==per[pa[0]]&&per[b]==per[pa[1]])//A和第一个人同性别,B和第二个人同性别
            {
                ans[index].a=pa[0];
                ans[index++].b=pa[1];
            }
        }
        return ;
    }
    else
    {
        for (int i=0;i<v[s].size();i++)
        {
            if (vis[v[s][i]]==0)
            {
                if (path==1&&per[v[s][i]]!=per[s])
                    continue;
                else if (path==3&&per[v[s][i]]!=per[t])
                    continue;
                else
                {
                    vis[v[s][i]]=1;//回溯
                    pa.push_back(v[s][i]);
                    fun(v[s][i],t,path+1);
                    pa.pop_back();
                    vis[v[s][i]]=0;
                }

            }
        }
    }
}
int main()
{

    int n,m;
    char ta[10],tb[10];
    scanf("%d %d",&n,&m);
    for (int i=0;i<m;i++)
    {
        scanf("%s %s",&ta,&tb);
        a=getnum(ta);
        b=getnum(tb);
        if (getsign(ta))

            per[a]=1;
        else
            per[a]=0;
        if (getsign(tb))
            per[b]=1;
        else
            per[b]=0;
        v[a].push_back(b);
        v[b].push_back(a);
    }
    int k;
    scanf("%d",&k);
    for (int i=0;i<k;i++)
    {
        scanf("%d %d",&a,&b);
        if (a<0) a=-a;
        if (b<0) b=-b;
        index=0;
        vis[a]=1;
        fun(a,b,1);
        vis[a]=0;
        sort(ans,ans+index,cmp);
        printf("%d\n",index);
        for (int j=0;j<index;j++)
        {
            printf("%04d %04d\n",ans[j].a,ans[j].b);
        }
    }
    return  0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值