Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.
Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤105) and then followed by N bets. The numbers are separated by a space.
Output Specification:
For each test case, print the winning number in a line. If there is no winner, print None
instead.
Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None
AC:
#include <iostream>
#include <cmath>
#include <vector>
using namespace std;
int n;
struct number
{
int id, num;
}nn;
int mx = -1;
bool flag = false;
int arr[100000+5] = {0}, num;
vector<number> v;
int main()
{
scanf("%d", &n);
for(int i = 0; i < n; i++)
{
scanf("%d", &num);
nn.id = i;
nn.num = num;
v.push_back(nn);
arr[num] += 1;
}
for(int i = 0; i < v.size(); i++)
{
if(arr[v[i].num] == 1)
{
printf("%d", v[i].num);
flag = true;
break;
}
}
if(!flag) printf("None");
return 0;
}
刚开始打算用数字下标记录,忽略了顺序,后面改为vector,ok了