PAT甲级 -- 1135 Is It A Red-Black Tree (30 分)

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpgrbf2.jpgrbf3.jpg
Figure 1Figure 2Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

 关于红黑树的科普:http://www.360doc.com/content/18/0904/19/25944647_783893127.shtml

红黑树不是一种AVL树,红黑树相对于AVL树来说,牺牲了部分平衡性以换取插入/删除操作时少量的旋转操作,整体来说性能要优于AVL树

 

 

 

拿到题目的思路:

1. 因为之前没接触过红黑树的概念,看到第二条就蒙圈了。不是每个叶子是黑色的吗????图一也不是这个亚子啊!!而且只给前序怎么建树啊啊啊啊啊???于是搜索了关于红黑树的概念,原来是棵类AVL树,这就可以建树了!!

2. 感觉红黑树的调整比AVL树的调整还要复杂!!

3. 有三个点可以判断:

(1)每个红色结点的子节点必须是黑色

(2)根节点是黑色, 即前序第一个结点的值必须大于0

(3)判断从结点到后代叶子上的黑色结点个数

4. 有了思路,但是实战经验太少,加上递归是我的短板....还是憋不出来,求助柳婥大神!

 

 

柳神的思路:

1. 先建树
2. 判断根结点(题目所给先序的第一个点即根结点)是否是黑色【pre[0] < 0】
2. 根据建立的树,从根结点开始遍历,如果当前结点是红色,判断它的孩子节点是否为黑色,递归返回结果【judge1函数】

3. 从根节点开始,递归遍历,检查每个结点的左子树的高度和右子树的高度(这里的高度指黑色结点的个数),比较左右孩子高度是否相等,递归返回结果【judge2函数】

 

#include <iostream>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;

struct node
{
	int value;
	node* left, *right;
};

node* buildTree(node* root, int v)  //建树
{
	if (root == NULL){  //该结点是NULL,新建结点
		root = new node();
		root->value = v;
		root->left = root->right = NULL;
	}else if(abs(v) < abs(root->value)){  //如果值比根小,去左子树
		root->left = buildTree(root->left, v);
	}else  //值比根大,去右子树
		root->right = buildTree(root->right, v);

	return root;
}

bool judge1(node* root) //判断每个红色结点的孩子都是黑色结点
{
	if(root == NULL) return true;
	if(root->value < 0){  //如果结点是红色结点,孩子结点是红色结点则发回false。
		if(root->left != NULL && root->left->value < 0) return false;  
		if(root->right != NULL && root->right->value < 0) return false;
	}
	return judge1(root->left) && judge1(root->right); //递归进行判断
}

int getBlackNum(node* root)  //得到黑色结点个数
{
	if(root == NULL) return 0;  //空为0
	int l = getBlackNum(root->left);  //左子树的黑色结点个数
	int r = getBlackNum(root->right); //右子树的黑色结点个数
	return root->value > 0? max(l, r)+1:max(l, r); //如果该结点是黑色,要+1  
}
bool judge2(node* root)  //判断黑色结点个数是否相等
{
	if (root == NULL) return true;  //结点是空,则返回true
	int l = getBlackNum(root->left); //左子树的黑色结点个数
	int r = getBlackNum(root->right);//右子树的黑色结点个数
	if(l != r) return false; //不相等,返回false
	return judge2(root->left) && judge2(root->right);  //递归进行判断
}

vector<int> pre;
int k, n;

int main(){
	scanf("%d", &k);
	for (int i = 0; i < k; i++){
		scanf("%d", &n);
		pre.resize(n);
		node* root = NULL;
		for (int j = 0; j < n; j++){
			scanf("%d", &pre[j]);
			root = buildTree(root, pre[j]);
		}

		if (pre[0] < 0 || judge1(root) == false || judge2(root) == false)
			printf("No\n");
		else printf("Yes\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值