PAT甲级 -- 1043 Is It a Binary Search Tree (25 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

我的思路:

1.假定这棵树是BST树,知道前序和中序,进行建树,建树过程中判断其是否满足BST树以及mirror BST的特征 ,尝试了一下,发现不能解,参考了柳神


 

柳神:

1. 学到了点东西,根据BST的性质,竟然可以直接根据BST的前序转后序!!!!啊啊啊啊,我应该学了假的数据结构把??因为BST的结构性质,根节点左子树的序列肯定比根要小,右子树的序列肯定比根要大!所以可以直接转换!!!右子树开始为第一个第一个比他大或相等的,左子树结束为第一个比他小的。

2. 最后输出的后序数组长度不为n,那就设isMirror为true,然后清空后序数组,重新再转换一次(根据镜面二叉搜索树的性质),如果依旧转换后数组大小不等于n,说明不是BTS。

#include <cstdio>
#include <vector>
using namespace std;
bool isMirror;
vector<int> pre, post;
void getpost(int root, int tail) {
    if(root > tail) return ;
    int i = root + 1, j = tail;
    if(!isMirror) {
        while(i <= tail && pre[root] > pre[i]) i++;
        while(j > root && pre[root] <= pre[j]) j--;
    } else {
        while(i <= tail && pre[root] <= pre[i]) i++;
        while(j > root && pre[root] > pre[j]) j--;
    }
    if(i - j != 1) return ;
    getpost(root + 1, j);
    getpost(i, tail);
    post.push_back(pre[root]);
}
int main() {
    int n;
    scanf("%d", &n);
    pre.resize(n);
    for(int i = 0; i < n; i++)
        scanf("%d", &pre[i]);
    getpost(0, n - 1);
    if(post.size() != n) {
        isMirror = true;
        post.clear();
        getpost(0, n - 1);
    }
    if(post.size() == n) {
        printf("YES\n%d", post[0]);
        for(int i = 1; i < n; i++)
            printf(" %d", post[i]);
    } else {
        printf("NO");
    }
    return 0;
}

补:

1. 自己又按照这个思路写了一遍,写错的点主要集中在while循环上面,对边界的把握不准,i是右子树的起点,应该找第一个 >=的,j是左子树的终点,应该找第一个 < 的;

#include <iostream>
#include <vector>
using namespace std;

int n;
bool isMirror = false;
vector<int> pre, post;


void getPost(int preL, int preR){
    if(preL > preR) return;
    int i = preL+1, j = preR;
    if(!isMirror){
        while(i <= preR && pre[i] < pre[preL]) i++;  //找右子树
        while(j > preL && pre[j] >= pre[preL]) j--;  //找左子树
    }else{
        while(i <= preR && pre[i] >= pre[preL]) i++; //找镜面左子树
        while(j > preL && pre[j] < pre[preL]) j--;  //找右子树
    }

    if(i - j != 1) return;
    getPost(preL+1, j);
    getPost(i, preR);
    post.push_back(pre[preL]);
    
}
int main(){
    scanf("%d", &n);
    pre.resize(n);
    for(int i = 0; i < n; i++){
        scanf("%d", &pre[i]);
    }
    getPost(0,n-1);
    if(post.size() != n){
        isMirror = true;
        post.clear();
        getPost(0, n-1);
    }
    if(post.size() != n){
        printf("NO\n");
    }else{
        printf("YES\n");
        printf("%d", post[0]);
        for(int i = 1; i < n; i++){
            printf(" %d", post[i]);
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值