PAT甲级 -- 1045 Favorite Color Stripe (30 分)

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10​4​​) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

我的思路:

1. 刚开始接触动态规划,看过的也就胡凡算法笔记上面几个比较经典的解法。 有点蒙蔽,想了半天没想出出来好的解决办法,也不想用模拟做,于是去看了柳神的代码

 

 

 

 

柳神:

1.  关键点是怎么把颜色序列转化为所熟知的dp的LIS的做法!这点看到柳神的解法之后真的感叹妙哉!

2. 用book[i] = j 表示颜色i的下标为 j

3. 在存储给定颜色的时候,用下标存储,得到的就是要求最长不下降子序列(LIS) !太妙了!!!

4. 再来说说LIS,令dp【i】表示以 a【i】结尾的最长不下降子序列的长度

(1)若存在a【j】 <= a【i】 并且 dp【j】 + 1 > dp【i】, 那么就更新dp【i】

(2)如果a【i】之前都比a【i】小,则a【i】只能自成序列,长度为1

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;

int n, m, l;
int book[201], a[10001], dp[10001];
int num = 0;

int main() {
	scanf("%d", &n);
	scanf("%d", &m);
	for(int i = 1;i <= m; i++){
		int color;
		scanf("%d", &color);
		book[color] = i;
	}
	scanf("%d", &l);
	for(int i = 0; i < l; i++){
		int x;
		scanf("%d", &x);
		if(book[x] >= 1)
			a[num++] = book[x];
	}
	int ans = -1;
	for(int i = 0; i < num; i++){
		dp[i] = 1;
		for(int j = 0; j < i; j++){
			if(a[i] >= a[j] && (dp[j] + 1 > dp[i])){
				dp[i] = dp[j] + 1;
			}
		}
		ans = max(ans, dp[i]);
	}
	printf("%d", ans);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值