PAT甲级真题 1045 Favorite Color Stripe (30分) C++实现 (动态规划,最长不下降子序列(LIS))

题目

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (<=200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (<=10000) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:
6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6
Sample Output:
7

思路

首先把最后一行输入中不喜欢的颜色忽略掉,不影响最后结果。

seq[i]记录喜欢颜色的序列号,问题即转化成了求最长不下降子序列(LIS),可参考:

浅谈最长不下降子序列与最长上升子序列

有复杂度O(nlogn)的解法(动态规划是O(n^2))。

简单起见,使用动态规划法。用a[i]记录包含第i块颜色时能达到的最大长度。一旦包含了第i个颜色,排除掉其前面所有不符合要求的颜色后,找可行颜色a[j]中最大值,加上这个颜色本身,即是包含该颜色后能达到的最大值。如果有一个颜色连续出现,只需与其最右侧一个比较即可。

a[i]中最大值即是所求最大值。

递推方程是:

a[i] = max{a[i], a[j]+1}, j∈[0, i)且j处的颜色序列不超过i的颜色序列

代码

#include <iostream>
#include <vector>
using namespace std;

int main(){
    int n, m;
    cin >> n >> m;
    vector<int> seq(n+1);  //记录喜欢颜色的位置
    for(int i = 0; i < m; i++){
        int temp;
        cin >> temp;
        seq[temp] = i + 1;
    }
    int l;
    cin >> l;
    vector<int> c;  //记录颜色
    for (int i=0; i<l; i++){
        int temp;
        cin >> temp;
        if (seq[temp]!=0){
            c.push_back(temp);
        }
    }
    l = c.size();  //排除不喜欢颜色后的数组大小
    //动态规划,a[i]记录包含第i块颜色时能达到的最大长度
    vector<int> a(l);  
    int totalMax = 0;
    for (int i=0; i<l; i++){
        a[i] = 1;
        int j = i - 1;
        while (j >= 0){
            if (seq[c[j]] <= seq[c[i]]){  //不违反序列规则
                a[i] = max(a[j]+1, a[i]);  //找其中最大的
            }
            while (j>=1 && c[j-1]==c[j]){  //跳过连续相同的颜色
                j--;
            }
            j--;
        }
        totalMax = max(a[i], totalMax);  //记录所有a[i]中最大值
    }
    cout << totalMax << endl;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值