1388 - Graveyard (Time limit: 3.000 seconds)

题目:

Programming contests became so popular in the year 2397 that the governor of New Earck — the largest human-inhabited planet of the galaxy — opened a special Alley of Contestant Memories (ACM) at the local graveyard. The ACM encircles a green park, and holds the holographic statues of famous contestants placed equidistantly along the park perimeter. The alley has to be renewed from time to time when a new group of memorials arrives.
When new memorials are added, the exact place for each can be selected arbitrarily along the ACM, but the equidistant disposition must be maintained by moving some of the old statues along the alley. Surprisingly, humans are still quite superstitious in 24th century: the graveyard keepers believe the holograms are holding dead people souls, and thus always try to renew the ACM with minimal possible movements of existing statues (besides, the holographic equipment is very heavy). Statues are moved along the park perimeter. Your work is to find a renewal plan which minimizes the sum of travel distances of all statues. Installation of a new hologram adds no distance penalty, so choose the places
for newcomers wisely!

Input
The input file contains several test cases, each of them consists of a a line that contains two integer numbers: n — the number of holographic statues initially located at the ACM, and m — the number of statues to be added (2 ≤ n ≤ 1000, 1 ≤ m ≤ 1000). The length of the alley along the park perimeter is exactly 10 000 feet.

Output
For each test case, write to the output a line with a single real number — the minimal sum of travel distances of all statues (in feet). The answer must be precise to at least 4 digits after decimal point.

Note:
Pictures show the first three examples. Marked circles denote original statues, empty circles denote new equidistant places, arrows denote movement plans for existing statues.

Sample Input
21 23 31 10 10

Sample Output
1666.6667
1000.0
1666.6667
0.0


题解

在新statues加入后,需要挪动老的statues以使所有的statues(新的和老的一起)均匀分配。这里有几点很重要:
(1)加入后,statues与statues之间的距离变小了,所以,在新区间内(端点只包含左边那个)最多只有一个statues;
(2)老的statues在挪动时,因为尽量挪动最短的距离,所以不会出现冲突(即两个statues挪到同一个地方),要证明这一点,只需要证明两个相邻的新区间内的statues在挪动时不会选择同一个地方。
(3)接下来就只剩一步了,那就是求老区间长度(这里不是真正的长度,而是变化之后得到的一个整数)和新区间长度的lcd,求lcd要借助gcd。
(4)具体细节见代码


提交代码

#include<stdio.h>

//a+b!=0
int gcd(int a,int b){
    if(a%b==0)
        return b;
    else
        return gcd(b,a%b);
}



int main(){
    int a,b;
    int units;
    int lcm;
    int dx,dy;

    while(scanf("%d%d",&a,&b)!=EOF){
        lcm=a*(a+b)/gcd(a,a+b);
        dx=lcm/a;
        dy=lcm/(a+b);
        units=0;

        for(int i=1;i<a;i++)
        {
            int n=(i*dx)%dy;
            units+=n<(dy-n)?n:(dy-n);
        }
        //printf("%d,%d\n",lcm,units);

        printf("%.4lf\n",10000.0*units/lcm);
    }

    return 0;
}

运行结果

这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值