HDU 6188 贪心

 

Nike likes playing cards and makes a problem of it. Now give you n integers, ai(1≤in) We define two identical numbers (eg: 2,2) a Duizi, and three consecutive positive integers (eg: 2,3,4) a Shunzi. Now you want to use these integers to form Shunzi and Duizi as many as possible. Let s be the total number of the Shunzi and the Duizi you formed. Try to calculate max(s)

. Each number can be used only once.

Input The input contains several test cases. For each test case, the first line contains one integer n(1≤n≤106). Then the next line contains n space-separated integers ai (1≤ain) Output For each test case, output the answer in a line. Sample Input

7
1 2 3 4 5 6 7
9
1 1 1 2 2 2 3 3 3
6
2 2 3 3 3 3 
6
1 2 3 3 4 5

Sample Output

2
4
3
2


        
  

Hint

Case 1(1,2,3)(4,5,6)

Case 2(1,2,3)(1,1)(2,2)(3,3)

Case 3(2,2)(3,3)(3,3)

Case 4(1,2,3)(3,4,5)



 

 

 一点点从头开始。我们慢慢学贪心。嘻嘻贪恋韩容心。

 

对子:2张;

顺子:3张;

所以优先考虑对子。

前两张不可能存在顺子,所以挑对子;

从第三张开始,先判断能否与前面的剩下的牌形成顺子(只需要一张牌就使得cnt+1);

不能形成顺子再考虑对子。

要考虑最小花费,一定要每步最优化。

 

 

#include<cstdio>
#include<cstring>
using namespace std;
int a[1000010];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(a,0,sizeof(a));
        for(int i = 0; i < n; i++)
        {
            int h;
            scanf("%d",&h);
            a[h]++;
        }
        int cnt = 0;
        for(int i = 1; i <= n; i++)
        {
            if(i <= 2) {
                cnt += a[i] / 2 ;
                a[i] %= 2;
            }
            else {
                if(a[i] && a[i-1] && a[i-2]){
                    a[i]--;a[i-1]--;a[i-2]--;
                    cnt++;
                }
                cnt+=a[i]/2;
                a[i] %= 2;
            }
        }
        printf("%d\n",cnt);
    }
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值